summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/readarr-bin/Manifest (renamed from www-apps/readarr/Manifest)0
-rw-r--r--www-apps/readarr-bin/files/readarr.init (renamed from www-apps/readarr/files/readarr.init)0
-rw-r--r--www-apps/readarr-bin/files/readarr.logrotate (renamed from www-apps/readarr/files/readarr.logrotate)0
-rw-r--r--www-apps/readarr-bin/files/readarr.service (renamed from www-apps/readarr/files/readarr.service)0
-rw-r--r--www-apps/readarr-bin/metadata.xml (renamed from www-apps/readarr/metadata.xml)0
-rw-r--r--www-apps/readarr-bin/readarr-bin-0.3.20.2452.ebuild77
-rw-r--r--www-apps/readarr/readarr-0.3.20.2452.ebuild66
7 files changed, 77 insertions, 66 deletions
diff --git a/www-apps/readarr/Manifest b/www-apps/readarr-bin/Manifest
index 71c021c6cbd2..71c021c6cbd2 100644
--- a/www-apps/readarr/Manifest
+++ b/www-apps/readarr-bin/Manifest
diff --git a/www-apps/readarr/files/readarr.init b/www-apps/readarr-bin/files/readarr.init
index 88cdbc9f597d..88cdbc9f597d 100644
--- a/www-apps/readarr/files/readarr.init
+++ b/www-apps/readarr-bin/files/readarr.init
diff --git a/www-apps/readarr/files/readarr.logrotate b/www-apps/readarr-bin/files/readarr.logrotate
index 4675f682b629..4675f682b629 100644
--- a/www-apps/readarr/files/readarr.logrotate
+++ b/www-apps/readarr-bin/files/readarr.logrotate
diff --git a/www-apps/readarr/files/readarr.service b/www-apps/readarr-bin/files/readarr.service
index c96ba634b514..c96ba634b514 100644
--- a/www-apps/readarr/files/readarr.service
+++ b/www-apps/readarr-bin/files/readarr.service
diff --git a/www-apps/readarr/metadata.xml b/www-apps/readarr-bin/metadata.xml
index 49ea8bc60df5..49ea8bc60df5 100644
--- a/www-apps/readarr/metadata.xml
+++ b/www-apps/readarr-bin/metadata.xml
diff --git a/www-apps/readarr-bin/readarr-bin-0.3.20.2452.ebuild b/www-apps/readarr-bin/readarr-bin-0.3.20.2452.ebuild
new file mode 100644
index 000000000000..5ef7e008750e
--- /dev/null
+++ b/www-apps/readarr-bin/readarr-bin-0.3.20.2452.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="An ebook and audiobook collection manager for Usenet and BitTorrent users"
+HOMEPAGE="https://readarr.com/
+ https://github.com/Readarr/Readarr/"
+
+SRC_URI="
+ amd64? (
+ elibc_glibc? (
+ https://github.com/Readarr/Readarr/releases/download/v${PV}/Readarr.develop.${PV}.linux-core-x64.tar.gz
+ )
+ elibc_musl? (
+ https://github.com/Readarr/Readarr/releases/download/v${PV}/Readarr.develop.${PV}.linux-musl-core-x64.tar.gz
+ )
+ )
+ arm? (
+ elibc_glibc? (
+ https://github.com/Readarr/Readarr/releases/download/v${PV}/Readarr.develop.${PV}.linux-core-arm.tar.gz
+ )
+ elibc_musl? (
+ https://github.com/Readarr/Readarr/releases/download/v${PV}/Readarr.develop.${PV}.linux-musl-core-arm.tar.gz
+ )
+ )
+ arm64? (
+ elibc_glibc? (
+ https://github.com/Readarr/Readarr/releases/download/v${PV}/Readarr.develop.${PV}.linux-core-arm64.tar.gz
+ )
+ elibc_musl? (
+ https://github.com/Readarr/Readarr/releases/download/v${PV}/Readarr.develop.${PV}.linux-musl-core-arm64.tar.gz
+ )
+ )
+"
+S="${WORKDIR}/Readarr"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="bindist strip test"
+
+RDEPEND="
+ acct-group/readarr
+ acct-user/readarr
+ dev-libs/icu
+ dev-util/lttng-ust:0
+ dev-db/sqlite
+"
+
+QA_PREBUILT="*"
+
+src_prepare() {
+ default
+
+ # https://github.com/dotnet/runtime/issues/57784
+ rm libcoreclrtraceptprovider.so Readarr.Update/libcoreclrtraceptprovider.so || die
+}
+
+src_install() {
+ newinitd "${FILESDIR}/readarr.init" readarr
+
+ keepdir /var/lib/readarr
+ fowners -R readarr:readarr /var/lib/readarr
+
+ insinto /etc/logrotate.d
+ insopts -m0644 -o root -g root
+ newins "${FILESDIR}/readarr.logrotate" readarr
+
+ dodir "/opt/readarr"
+ cp -R "${S}/." "${D}/opt/readarr" || die "Install failed!"
+
+ systemd_dounit "${FILESDIR}/readarr.service"
+ systemd_newunit "${FILESDIR}/readarr.service" "readarr@.service"
+}
diff --git a/www-apps/readarr/readarr-0.3.20.2452.ebuild b/www-apps/readarr/readarr-0.3.20.2452.ebuild
deleted file mode 100644
index 37c24ad2fa29..000000000000
--- a/www-apps/readarr/readarr-0.3.20.2452.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit systemd
-
-SRC_URI="
- amd64? (
- elibc_glibc? ( https://github.com/Readarr/Readarr/releases/download/v${PV}/Readarr.develop.${PV}.linux-core-x64.tar.gz )
- elibc_musl? ( https://github.com/Readarr/Readarr/releases/download/v${PV}/Readarr.develop.${PV}.linux-musl-core-x64.tar.gz )
- )
- arm? (
- elibc_glibc? ( https://github.com/Readarr/Readarr/releases/download/v${PV}/Readarr.develop.${PV}.linux-core-arm.tar.gz )
- elibc_musl? ( https://github.com/Readarr/Readarr/releases/download/v${PV}/Readarr.develop.${PV}.linux-musl-core-arm.tar.gz )
- )
- arm64? (
- elibc_glibc? ( https://github.com/Readarr/Readarr/releases/download/v${PV}/Readarr.develop.${PV}.linux-core-arm64.tar.gz )
- elibc_musl? ( https://github.com/Readarr/Readarr/releases/download/v${PV}/Readarr.develop.${PV}.linux-musl-core-arm64.tar.gz )
- )
-"
-
-DESCRIPTION="An ebook and audiobook collection manager for Usenet and BitTorrent users"
-HOMEPAGE="https://readarr.com/"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-RESTRICT="bindist strip test"
-
-RDEPEND="
- acct-group/readarr
- acct-user/readarr
- dev-libs/icu
- dev-util/lttng-ust:0
- dev-db/sqlite
- sys-libs/glibc
-"
-
-QA_PREBUILT="*"
-
-S="${WORKDIR}/Readarr"
-
-src_prepare() {
- default
-
- # https://github.com/dotnet/runtime/issues/57784
- rm libcoreclrtraceptprovider.so Readarr.Update/libcoreclrtraceptprovider.so || die
-}
-
-src_install() {
- newinitd "${FILESDIR}/${PN}.init" ${PN}
-
- keepdir /var/lib/${PN}
- fowners -R ${PN}:${PN} /var/lib/${PN}
-
- insinto /etc/logrotate.d
- insopts -m0644 -o root -g root
- newins "${FILESDIR}/${PN}.logrotate" ${PN}
-
- dodir "/opt/${PN}"
- cp -R "${S}/." "${D}/opt/readarr" || die "Install failed!"
-
- systemd_dounit "${FILESDIR}/readarr.service"
- systemd_newunit "${FILESDIR}/readarr.service" "${PN}@.service"
-}