summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/phpsysinfo/Manifest1
-rw-r--r--www-apps/phpsysinfo/phpsysinfo-3.4.3.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/www-apps/phpsysinfo/Manifest b/www-apps/phpsysinfo/Manifest
index 029b57c9f824..54cfa9b8717c 100644
--- a/www-apps/phpsysinfo/Manifest
+++ b/www-apps/phpsysinfo/Manifest
@@ -1 +1,2 @@
DIST phpsysinfo-3.4.2.tar.gz 1018093 BLAKE2B 148111015d2ba0751f4001d8b00ac30ca0c82eb21d6f44eb42b309a50d343d2aa765da032ecd2e018ecf420dfb32fbe78b0a4a06fd248a86c388a9dcf0c60014 SHA512 b375319cc54e7291089db8f938fae92a9245bc95318116159d34fcfa33464063eaf5b911a928c3d48adbfcb98d9b4431e85052b76c4f3a03a0ddc7f14557db39
+DIST phpsysinfo-3.4.3.tar.gz 1101922 BLAKE2B b4800af1bb6995f898681d80c95c87d7120146078b1a0f24d65c0217b6c6ea1d9dc9e9a8c54d9e4c1f41988ed68e28f263093af1217caf76af48b001da912136 SHA512 d0c5f0d36da6fa85dd299c8550633055fecc15e16f0f9a57e6765691a0c766da9893fd2be539492fb45b482165b1215ca9950b50f7bddfa84294833c06de27f7
diff --git a/www-apps/phpsysinfo/phpsysinfo-3.4.3.ebuild b/www-apps/phpsysinfo/phpsysinfo-3.4.3.ebuild
new file mode 100644
index 000000000000..5b4d162c33df
--- /dev/null
+++ b/www-apps/phpsysinfo/phpsysinfo-3.4.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature webapp
+
+DESCRIPTION="A customizable PHP script that displays information about your system nicely"
+HOMEPAGE="https://phpsysinfo.github.io/phpsysinfo/"
+SRC_URI="https://github.com/rk4an/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+RDEPEND="
+ dev-lang/php[simplexml,xml,xsl(+),xslt(+),unicode]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG.md README*
+ rm CHANGELOG.md COPYING README* .gitignore || die
+
+ mv phpsysinfo.ini{.new,} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/phpsysinfo.ini
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ optfeature "showing disk temperatures." app-admin/hddtemp
+ optfeature "showing system uptime." app-misc/uptimed
+ optfeature "showing snmp statistics." net-analyzer/net-snmp
+ optfeature "showing iptables rules." net-firewall/iptables
+ optfeature "showing ipmi sensors." sys-apps/ipmitool
+ optfeature "showing ipmi sensors." sys-apps/ipmiutil
+ optfeature "showing system sensors." sys-apps/lm-sensors
+ optfeature "showing s.m.a.r.t. health." sys-apps/smartmontools
+ optfeature "showing lsi raid controller health." sys-block/megactl
+ optfeature "showing fake raid statistics." sys-fs/dmraid
+ optfeature "showing software raid statistics." sys-fs/mdadm
+ optfeature "showing quota information." sys-fs/quota
+ optfeature "showing ipmi sensors." sys-libs/freeipmi
+ optfeature "showing apc ups statistics." sys-power/apcupsd
+ optfeature "showing ups statistics." sys-power/nut
+}