summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/chromium/chromium-70.0.3538.54.ebuild')
-rw-r--r--www-client/chromium/chromium-70.0.3538.54.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/www-client/chromium/chromium-70.0.3538.54.ebuild b/www-client/chromium/chromium-70.0.3538.54.ebuild
index 536322cbe16a..6f9776159858 100644
--- a/www-client/chromium/chromium-70.0.3538.54.ebuild
+++ b/www-client/chromium/chromium-70.0.3538.54.ebuild
@@ -101,11 +101,16 @@ DEPEND="${COMMON_DEPEND}
sys-apps/hwids[usb(+)]
>=sys-devel/bison-2.4.3
sys-devel/flex
- >=sys-devel/clang-5
virtual/pkgconfig
dev-vcs/git
"
+: ${CHROMIUM_FORCE_CLANG=yes}
+
+if [[ ${CHROMIUM_FORCE_CLANG} == yes ]]; then
+ DEPEND+=" >=sys-devel/clang-5"
+fi
+
if ! has chromium_pkg_die ${EBUILD_DEATH_HOOKS}; then
EBUILD_DEATH_HOOKS+=" chromium_pkg_die";
fi
@@ -381,7 +386,7 @@ src_configure() {
# Make sure the build system will use the right tools, bug #340795.
tc-export AR CC CXX NM
- if ! tc-is-clang; then
+ if [[ ${CHROMIUM_FORCE_CLANG} == yes ]] && ! tc-is-clang; then
# Force clang since gcc is pretty broken at the moment.
CC=${CHOST}-clang
CXX=${CHOST}-clang++