summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/falkon/files/falkon-22.04.3-python3.patch')
-rw-r--r--www-client/falkon/files/falkon-22.04.3-python3.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/www-client/falkon/files/falkon-22.04.3-python3.patch b/www-client/falkon/files/falkon-22.04.3-python3.patch
new file mode 100644
index 000000000000..cd1025cbfda4
--- /dev/null
+++ b/www-client/falkon/files/falkon-22.04.3-python3.patch
@@ -0,0 +1,32 @@
+From 67199ef5f470dadab17401f3aad8770ec058c111 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 17 Jul 2022 12:45:25 +0200
+Subject: [PATCH] Python3 must be found first
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 950c03adc..aa91e745e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -130,12 +130,12 @@ if (KF5Wallet_FOUND AND KF5KIO_FOUND AND KF5Crash_FOUND AND KF5CoreAddons_FOUND
+ endif()
+
+ # Optional: PySide2
++find_package(Python3 COMPONENTS Development)
+ find_package(PySide2 "2.0.0")
+ find_package(Shiboken2 "2.0.0")
+-find_package(Python3 COMPONENTS Development)
++set_package_properties(Python3 PROPERTIES DESCRIPTION "Python plugins" TYPE OPTIONAL)
+ set_package_properties(PySide2 PROPERTIES DESCRIPTION "Python plugins" TYPE OPTIONAL)
+ set_package_properties(Shiboken2 PROPERTIES DESCRIPTION "Python plugins" TYPE OPTIONAL)
+-set_package_properties(Python3 PROPERTIES DESCRIPTION "Python plugins" TYPE OPTIONAL)
+ if (PySide2_FOUND AND Shiboken2_FOUND AND Python3_FOUND)
+ set(ENABLE_PYTHON_PLUGINS TRUE)
+ endif()
+--
+2.35.1
+