summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-68.3.0.ebuild')
-rw-r--r--www-client/firefox/firefox-68.3.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/www-client/firefox/firefox-68.3.0.ebuild b/www-client/firefox/firefox-68.3.0.ebuild
index 8c9aed8335dd..34e4cce040c9 100644
--- a/www-client/firefox/firefox-68.3.0.ebuild
+++ b/www-client/firefox/firefox-68.3.0.ebuild
@@ -52,8 +52,8 @@ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
SLOT="0"
LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
IUSE="bindist clang cpu_flags_x86_avx2 dbus debug eme-free geckodriver
- +gmp-autoupdate hardened hwaccel jack lto neon pgo pulseaudio
- +screenshot selinux startup-notification +system-av1
+ +gmp-autoupdate hardened hwaccel jack lto cpu_flags_arm_neon
+ pgo pulseaudio +screenshot selinux startup-notification +system-av1
+system-harfbuzz +system-icu +system-jpeg +system-libevent
+system-sqlite +system-libvpx +system-webp test wayland wifi"
@@ -455,7 +455,7 @@ src_configure() {
fi
# Modifications to better support ARM, bug 553364
- if use neon ; then
+ if use cpu_flags_arm_neon ; then
mozconfig_annotate '' --with-fpu=neon
if ! tc-is-clang ; then
@@ -464,6 +464,7 @@ src_configure() {
mozconfig_annotate '' --with-thumb-interwork=no
fi
fi
+
if [[ ${CHOST} == armv*h* ]] ; then
mozconfig_annotate '' --with-float-abi=hard
if ! use system-libvpx ; then