summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins/gecko-mediaplayer/gecko-mediaplayer-1.0.8.ebuild')
-rw-r--r--www-plugins/gecko-mediaplayer/gecko-mediaplayer-1.0.8.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/www-plugins/gecko-mediaplayer/gecko-mediaplayer-1.0.8.ebuild b/www-plugins/gecko-mediaplayer/gecko-mediaplayer-1.0.8.ebuild
new file mode 100644
index 000000000000..303b193df20a
--- /dev/null
+++ b/www-plugins/gecko-mediaplayer/gecko-mediaplayer-1.0.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit multilib nsplugins
+
+DESCRIPTION="A browser plugin that uses GNOME MPlayer"
+HOMEPAGE="http://code.google.com/p/gecko-mediaplayer/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="+curl"
+
+RDEPEND=">=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.30
+ dev-libs/nspr
+ >=media-libs/gmtk-${PV}
+ >=media-video/gnome-mplayer-${PV}[dbus]
+ curl? ( net-misc/curl )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ >=net-misc/npapi-sdk-0.27
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS="ChangeLog DOCS/tech/*.txt"
+
+src_configure() {
+ econf \
+ --with-plugin-dir=/usr/$(get_libdir)/${PLUGINS_DIR} \
+ $(use_with curl libcurl)
+}
+
+src_install() {
+ default
+ rm -rf "${ED}"/usr/share/doc/${PN}
+}