summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/varnish/Manifest3
-rw-r--r--www-servers/varnish/varnish-6.0.1.ebuild102
-rw-r--r--www-servers/varnish/varnish-6.1.1.ebuild103
-rw-r--r--www-servers/varnish/varnish-6.3.1.ebuild98
4 files changed, 0 insertions, 306 deletions
diff --git a/www-servers/varnish/Manifest b/www-servers/varnish/Manifest
index 7c307a635894..e60281b3d7f4 100644
--- a/www-servers/varnish/Manifest
+++ b/www-servers/varnish/Manifest
@@ -1,6 +1,3 @@
-DIST varnish-6.0.1.tgz 3065822 BLAKE2B b99d0d50444872353367007f2ee97c5d5f0e60031ece7b07f8b2c3a7a84b31be88fe2b850304b1f2e47a35f35c2c41f43888bee1d1874721a72ad078acfddfa1 SHA512 057cb69ae6a4d980401effb7561d3a9b537216d8626fdf4e7bcc75971958517f51b6bd7f7af86c11bc92a2e77876831c577736dfcd11447ad0128f222c5ad138
DIST varnish-6.0.6.tgz 3136931 BLAKE2B 2ce379622b20a939a977a426cb842ba62e4fd5fd3ba785ec21888956b6a8c16e95bd834962a7ba05dc426dfc36067cabb4f8ade2bee7fe2a094a1f2c4c4c9e06 SHA512 c0881ab051bca928c12f35494c5e2a8109390abdf3acf368da404c5537d1ee0f1153b6e329058a7e1168eacf5af9b86ccf9a6e58cd89dd7d51b8b71d25aa7ba0
-DIST varnish-6.1.1.tgz 3135623 BLAKE2B c39904fe2745ab601e7c1f6d85850fe1a83c19e8d80e8af5a60ac5f134817b26b3274ba62c78c3839fd7e6c2da3e58b6c211a7452d37dd864f0f658d500a6138 SHA512 67e546e5fee2d10ec038d7b011a3f61a0a056ce8a4813556526c8fce23bb1fe4e29952a773e6cbc2433c0228971a5e90693d5ce61f6cb5f2242e055e0ce13d18
-DIST varnish-6.3.1.tgz 3306392 BLAKE2B d34e52567fc0a9c57ac894c79155b43279a7b1549651494053f3eca3ddf83d234e41cffa4fed4833535b3c07e2a62ec0f54a1cc69c1bd689fee4ab90252f6588 SHA512 2fee11bcd01f53464b53e8271c2aec08233af078f2e9a2600cd82efbf646b3fd48160ebb2add09e1fb4f43e18e61f21a2408e351eeb2a567179733a3efbc3ddc
DIST varnish-6.3.2.tgz 3323908 BLAKE2B 5bde1b2ececeb8aed884db22ed75bfd74f82d68416e71400a4c0d27483fcceb029fe8e724e30754899c872d7028da5cb759545f0743a11d0e90b0fd604af0ad7 SHA512 0f476c642df834737d446b3bc6ac8afa5981d1de5810dc6e8556eb22b2ca26d64eb531f4ad3332eb86e231a7443fe35393177ec6dbee97a837f405d1aa9d03cd
DIST varnish-6.4.0.tgz 3404617 BLAKE2B 0ef0f7303f5c926bb1b80ec14cdd9755d65c1938fa8645240800ac2997f954022133625a74dd9c30ce21850674c3b00777fcc896309f528e6ba90d347333d7f7 SHA512 cda8f9e1d301a2b79db14685a23e25e36225f37065a1b7f37c5ae12fbb0483be51be9ffcc8ba72c1f65f5a022d1e408825694daed6780e206b9ba91feb2a07a1
diff --git a/www-servers/varnish/varnish-6.0.1.ebuild b/www-servers/varnish/varnish-6.0.1.ebuild
deleted file mode 100644
index b259b36b803d..000000000000
--- a/www-servers/varnish/varnish-6.0.1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit user autotools systemd python-r1
-
-DESCRIPTION="Varnish is a state-of-the-art, high-performance HTTP accelerator"
-HOMEPAGE="https://varnish-cache.org/"
-SRC_URI="http://varnish-cache.org/_downloads/${P}.tgz"
-
-LICENSE="BSD-2 GPL-2"
-SLOT="0/1"
-KEYWORDS="amd64 ~mips ~ppc ~ppc64 x86"
-IUSE="jemalloc jit static-libs"
-
-CDEPEND="
- sys-libs/readline:0=
- dev-libs/libpcre[jit?]
- jemalloc? ( dev-libs/jemalloc )
- sys-libs/ncurses:0="
-
-#varnish compiles stuff at run time
-RDEPEND="
- ${PYTHON_DEPS}
- ${CDEPEND}
- sys-devel/gcc"
-
-DEPEND="
- ${CDEPEND}
- dev-python/docutils
- virtual/pkgconfig"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RESTRICT="test" #315725
-
-pkg_setup() {
- ebegin "Creating varnish user and group"
- enewgroup varnish
- enewuser varnish -1 -1 /var/lib/varnish varnish
- eend $?
-}
-
-src_prepare() {
- # Remove -Werror bug #528354
- sed -i -e 's/-Werror\([^=]\)/\1/g' configure.ac
-
- # Upstream doesn't put varnish.m4 in the m4/ directory
- # We link because the Makefiles look for the file in
- # the original location
- ln -sf ../varnish.m4 m4/varnish.m4
-
- eapply_user
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable static-libs static) \
- $(use_enable jit pcre-jit ) \
- $(use_with jemalloc)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- python_replicate_script "${D}/usr/share/varnish/vmodtool.py"
-
- newinitd "${FILESDIR}"/varnishlog.initd varnishlog
- newconfd "${FILESDIR}"/varnishlog.confd varnishlog
-
- newinitd "${FILESDIR}"/varnishncsa.initd varnishncsa
- newconfd "${FILESDIR}"/varnishncsa.confd varnishncsa
-
- newinitd "${FILESDIR}"/varnishd.initd-r4 varnishd
- newconfd "${FILESDIR}"/varnishd.confd-r4 varnishd
-
- insinto /etc/logrotate.d/
- newins "${FILESDIR}/varnishd.logrotate-r2" varnishd
-
- diropts -m750
-
- keepdir /var/lib/varnish
- keepdir /var/log/varnish
-
- systemd_dounit "${FILESDIR}/${PN}d.service"
-
- insinto /etc/varnish/
- doins lib/libvmod_std/vmod.vcc
- doins etc/example.vcl
-
- dodoc README.rst
- dodoc doc/changes.rst
-
- fowners root:varnish /etc/varnish/
- fowners varnish:varnish /var/lib/varnish/
- fperms 0750 /var/lib/varnish/ /etc/varnish/
-}
diff --git a/www-servers/varnish/varnish-6.1.1.ebuild b/www-servers/varnish/varnish-6.1.1.ebuild
deleted file mode 100644
index a335a46245c0..000000000000
--- a/www-servers/varnish/varnish-6.1.1.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit user autotools systemd python-r1
-
-DESCRIPTION="Varnish is a state-of-the-art, high-performance HTTP accelerator"
-HOMEPAGE="https://varnish-cache.org/"
-SRC_URI="http://varnish-cache.org/_downloads/${P}.tgz"
-
-LICENSE="BSD-2 GPL-2"
-SLOT="0/2"
-KEYWORDS="amd64 ~mips ~ppc ~ppc64 x86"
-IUSE="jemalloc jit static-libs"
-
-CDEPEND="
- sys-libs/readline:0=
- dev-libs/libpcre[jit?]
- jemalloc? ( dev-libs/jemalloc )
- sys-libs/ncurses:0="
-
-#varnish compiles stuff at run time
-RDEPEND="
- ${PYTHON_DEPS}
- ${CDEPEND}
- sys-devel/gcc"
-
-DEPEND="
- ${CDEPEND}
- dev-python/docutils
- dev-python/sphinx
- virtual/pkgconfig"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RESTRICT="test" #315725
-
-pkg_setup() {
- ebegin "Creating varnish user and group"
- enewgroup varnish
- enewuser varnish -1 -1 /var/lib/varnish varnish
- eend $?
-}
-
-src_prepare() {
- # Remove -Werror bug #528354
- sed -i -e 's/-Werror\([^=]\)/\1/g' configure.ac
-
- # Upstream doesn't put varnish.m4 in the m4/ directory
- # We link because the Makefiles look for the file in
- # the original location
- ln -sf ../varnish.m4 m4/varnish.m4
-
- eapply_user
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable static-libs static) \
- $(use_enable jit pcre-jit ) \
- $(use_with jemalloc)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- python_replicate_script "${D}/usr/share/varnish/vmodtool.py"
-
- newinitd "${FILESDIR}"/varnishlog.initd varnishlog
- newconfd "${FILESDIR}"/varnishlog.confd varnishlog
-
- newinitd "${FILESDIR}"/varnishncsa.initd varnishncsa
- newconfd "${FILESDIR}"/varnishncsa.confd varnishncsa
-
- newinitd "${FILESDIR}"/varnishd.initd-r4 varnishd
- newconfd "${FILESDIR}"/varnishd.confd-r4 varnishd
-
- insinto /etc/logrotate.d/
- newins "${FILESDIR}/varnishd.logrotate-r2" varnishd
-
- diropts -m750
-
- keepdir /var/lib/varnish
- keepdir /var/log/varnish
-
- systemd_dounit "${FILESDIR}/${PN}d.service"
-
- insinto /etc/varnish/
- doins lib/libvmod_std/vmod.vcc
- doins etc/example.vcl
-
- dodoc README.rst
- dodoc doc/changes.rst
-
- fowners root:varnish /etc/varnish/
- fowners varnish:varnish /var/lib/varnish/
- fperms 0750 /var/lib/varnish/ /etc/varnish/
-}
diff --git a/www-servers/varnish/varnish-6.3.1.ebuild b/www-servers/varnish/varnish-6.3.1.ebuild
deleted file mode 100644
index 15ef03524a05..000000000000
--- a/www-servers/varnish/varnish-6.3.1.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit autotools systemd python-r1
-
-DESCRIPTION="Varnish is a state-of-the-art, high-performance HTTP accelerator"
-HOMEPAGE="https://varnish-cache.org/"
-SRC_URI="http://varnish-cache.org/_downloads/${P}.tgz"
-
-LICENSE="BSD-2 GPL-2"
-SLOT="0/2"
-KEYWORDS="amd64 ~mips ~ppc ~ppc64 ~x86"
-IUSE="jemalloc jit static-libs"
-
-CDEPEND="
- sys-libs/readline:0=
- dev-libs/libpcre[jit?]
- jemalloc? ( dev-libs/jemalloc )
- sys-libs/ncurses:0="
-
-#varnish compiles stuff at run time
-RDEPEND="
- ${PYTHON_DEPS}
- ${CDEPEND}
- acct-user/varnish
- acct-group/varnish
- sys-devel/gcc"
-
-DEPEND="
- ${CDEPEND}
- dev-python/docutils
- dev-python/sphinx
- virtual/pkgconfig"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RESTRICT="test" #315725
-
-src_prepare() {
- # Remove -Werror bug #528354
- sed -i -e 's/-Werror\([^=]\)/\1/g' configure.ac
-
- # Upstream doesn't put varnish.m4 in the m4/ directory
- # We link because the Makefiles look for the file in
- # the original location
- ln -sf ../varnish.m4 m4/varnish.m4
-
- eapply_user
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable static-libs static) \
- $(use_enable jit pcre-jit ) \
- $(use_with jemalloc)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- python_replicate_script "${D}/usr/share/varnish/vmodtool.py"
-
- newinitd "${FILESDIR}"/varnishlog.initd varnishlog
- newconfd "${FILESDIR}"/varnishlog.confd varnishlog
-
- newinitd "${FILESDIR}"/varnishncsa.initd varnishncsa
- newconfd "${FILESDIR}"/varnishncsa.confd varnishncsa
-
- newinitd "${FILESDIR}"/varnishd.initd-r4 varnishd
- newconfd "${FILESDIR}"/varnishd.confd-r4 varnishd
-
- insinto /etc/logrotate.d/
- newins "${FILESDIR}/varnishd.logrotate-r2" varnishd
-
- diropts -m750
-
- keepdir /var/lib/varnish
- keepdir /var/log/varnish
-
- systemd_dounit "${FILESDIR}/${PN}d.service"
-
- insinto /etc/varnish/
- doins lib/libvmod_std/vmod.vcc
- doins etc/example.vcl
-
- dodoc README.rst
- dodoc doc/changes.rst
-
- fowners root:varnish /etc/varnish/
- fowners varnish:varnish /var/lib/varnish/
- fperms 0750 /var/lib/varnish/ /etc/varnish/
-}