summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/xdriinfo')
-rw-r--r--x11-apps/xdriinfo/Manifest2
-rw-r--r--x11-apps/xdriinfo/metadata.xml5
-rw-r--r--x11-apps/xdriinfo/xdriinfo-1.0.4.ebuild23
-rw-r--r--x11-apps/xdriinfo/xdriinfo-1.0.5.ebuild23
4 files changed, 53 insertions, 0 deletions
diff --git a/x11-apps/xdriinfo/Manifest b/x11-apps/xdriinfo/Manifest
new file mode 100644
index 000000000000..24b74457724a
--- /dev/null
+++ b/x11-apps/xdriinfo/Manifest
@@ -0,0 +1,2 @@
+DIST xdriinfo-1.0.4.tar.bz2 104296 SHA256 35c6e43d3b68ef5d93d013b4517014fb890bad96b2c801abf4f607927a94cb1c
+DIST xdriinfo-1.0.5.tar.bz2 121276 SHA256 4cba3766ef89557422062287248adeb933999071bad6f3ef9c0a478a3c680119 SHA512 6b7a3641f488d305f950c494464fd4b674ab3aaed5c7159d6d8ddad4587c18d680e5854bd80666444f1dee52eb4f46b45709a6d9c333593fe045c73e738524de WHIRLPOOL 771caf038bb15f174b85e5e930f5822ce559f53bd1b191206bf0a55f2f4619a0b018866b1bbe84adf55dbd6c7d4bec696b62ce89f57f9bd1223e7644da7c4e18
diff --git a/x11-apps/xdriinfo/metadata.xml b/x11-apps/xdriinfo/metadata.xml
new file mode 100644
index 000000000000..01c4c004e735
--- /dev/null
+++ b/x11-apps/xdriinfo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>
diff --git a/x11-apps/xdriinfo/xdriinfo-1.0.4.ebuild b/x11-apps/xdriinfo/xdriinfo-1.0.4.ebuild
new file mode 100644
index 000000000000..5e617ccd0efb
--- /dev/null
+++ b/x11-apps/xdriinfo/xdriinfo-1.0.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit xorg-2 flag-o-matic
+
+DESCRIPTION="query configuration information of DRI drivers"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ x11-proto/glproto"
+
+pkg_setup() {
+ xorg-2_pkg_setup
+
+ append-cppflags "-I${EPREFIX}/usr/lib64/opengl/xorg-x11/include/"
+
+}
diff --git a/x11-apps/xdriinfo/xdriinfo-1.0.5.ebuild b/x11-apps/xdriinfo/xdriinfo-1.0.5.ebuild
new file mode 100644
index 000000000000..ec780faea6cf
--- /dev/null
+++ b/x11-apps/xdriinfo/xdriinfo-1.0.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xorg-2 flag-o-matic multilib
+
+DESCRIPTION="query configuration information of DRI drivers"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ x11-proto/glproto"
+
+pkg_setup() {
+ xorg-2_pkg_setup
+
+ append-cppflags "-I${EPREFIX}/usr/$(get_libdir)/opengl/xorg-x11/include/"
+
+}