summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-base/xcb-proto/xcb-proto-1.15.2.ebuild')
-rw-r--r--x11-base/xcb-proto/xcb-proto-1.15.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-base/xcb-proto/xcb-proto-1.15.2.ebuild b/x11-base/xcb-proto/xcb-proto-1.15.2.ebuild
new file mode 100644
index 000000000000..40e67119e4ae
--- /dev/null
+++ b/x11-base/xcb-proto/xcb-proto-1.15.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..11} )
+XORG_TARBALL_SUFFIX="xz"
+XORG_MODULE=proto/
+
+inherit python-r1 xorg-3
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/proto/xcbproto"
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/xcbproto.git"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2
+"
+
+ECONF_SOURCE="${S}"
+
+src_configure() {
+ # Don't use Python to find sitedir here.
+ PYTHON=true default
+}
+
+src_compile() {
+ :
+}
+
+xcbgen_install() {
+ # Use eclass to find sitedir instead.
+ emake -C xcbgen install DESTDIR="${D}" pythondir="$(python_get_sitedir)"
+ python_optimize
+}
+
+src_install() {
+ # Restrict SUBDIRS to prevent xcbgen with empty sitedir.
+ emake install DESTDIR="${D}" SUBDIRS=src
+ python_foreach_impl xcbgen_install
+}