summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-base/xcb-proto')
-rw-r--r--x11-base/xcb-proto/xcb-proto-1.14-r1.ebuild (renamed from x11-base/xcb-proto/xcb-proto-1.14.ebuild)40
1 files changed, 25 insertions, 15 deletions
diff --git a/x11-base/xcb-proto/xcb-proto-1.14.ebuild b/x11-base/xcb-proto/xcb-proto-1.14-r1.ebuild
index 8d5daa5d6cc2..094dba7a380c 100644
--- a/x11-base/xcb-proto/xcb-proto-1.14.ebuild
+++ b/x11-base/xcb-proto/xcb-proto-1.14-r1.ebuild
@@ -17,26 +17,36 @@ EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/xcbproto.git"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND=""
-RDEPEND="${PYTHON_DEPS}"
-BDEPEND="dev-libs/libxml2"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2
+"
+
+ECONF_SOURCE="${S}"
+
+multilib_src_configure() {
+ # Don't use Python to find sitedir here.
+ PYTHON=true default
+}
-multilib_src_compile() {
- default
+src_compile() {
+ :
+}
- if multilib_is_native_abi; then
- python_foreach_impl emake -C xcbgen top_builddir="${BUILD_DIR}"
- fi
+xcbgen_install() {
+ # Use eclass to find sitedir instead.
+ emake -C xcbgen install DESTDIR="${D}" pythondir="$(python_get_sitedir)"
+ python_optimize
}
multilib_src_install() {
- default
-
- if multilib_is_native_abi; then
- python_foreach_impl emake -C xcbgen top_builddir="${BUILD_DIR}"
- python_foreach_impl python_optimize
- fi
+ # Restrict SUBDIRS to prevent xcbgen with empty sitedir.
+ emake install DESTDIR="${D}" SUBDIRS=src
+ multilib_is_native_abi && python_foreach_impl xcbgen_install
}