summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xwayland/Manifest1
-rw-r--r--x11-base/xwayland/metadata.xml1
-rw-r--r--x11-base/xwayland/xwayland-23.2.1.ebuild110
-rw-r--r--x11-base/xwayland/xwayland-9999.ebuild12
4 files changed, 122 insertions, 2 deletions
diff --git a/x11-base/xwayland/Manifest b/x11-base/xwayland/Manifest
index 86298681cb7d..4476391e8bb2 100644
--- a/x11-base/xwayland/Manifest
+++ b/x11-base/xwayland/Manifest
@@ -1,2 +1,3 @@
DIST xwayland-23.1.2.tar.xz 1287396 BLAKE2B 56e213ea9d8cfa0ab316fb0a09d623427b7fa6effc6feb2b1d4364ee494b54d82e1863fbba86f824b09bf07b0b83fe5e85595f5cd00fdfa38fd72923922c2ea4 SHA512 796939106e8c986f2e8d6a1ff27f3a51cda0718825c3a6da678573de95a61bcc9fac484a34c6f8f762f7078f5289aa35c393725ea0b0f7e5d153352ab01a48f5
DIST xwayland-23.2.0.tar.xz 1298020 BLAKE2B 7b4d1b74c8c8d537395dfb277ff012b2761c5e6dc2d5ed20ec0f8b7da35c04d000a20efaff9ea9d2097b5b7ab1df7778162ec23f4623d0a63e38a4253a7bfa06 SHA512 3b490839026da4d34136d50050397d87e205d4fdb9c3cc9896eb2980bf90f3c951e7ce5271d7f7379c56a376d36f9e1fe1242211b64e680b715dd065ea58532d
+DIST xwayland-23.2.1.tar.xz 1298128 BLAKE2B d871c83c1b5975f1cbd1ae2ee5ab693a277d992c1cd66d40b2b7159a49827e9208321ac7465f5706e2e85ac0c438548cc871a2f34e3391388317bd08aef161de SHA512 8ea3061a175c9163166c69569a81dbee2cad605d140dd25d9b61219db555e775811ebe9716c38b6fa6c591299b7c1dfcd5248e797e341ee4cea49b998be89657
diff --git a/x11-base/xwayland/metadata.xml b/x11-base/xwayland/metadata.xml
index 2df659c4c950..1c6df10259d6 100644
--- a/x11-base/xwayland/metadata.xml
+++ b/x11-base/xwayland/metadata.xml
@@ -8,6 +8,7 @@
<use>
<flag name="unwind">Enable libunwind usage for backtraces</flag>
<flag name="xcsecurity">Build Security extension</flag>
+ <flag name="libei">Enable emulated input using <pkg>dev-libs/libei</pkg></flag>
</use>
<upstream>
<remote-id type="cpe">cpe:/a:x.org:xorg-server</remote-id>
diff --git a/x11-base/xwayland/xwayland-23.2.1.ebuild b/x11-base/xwayland/xwayland-23.2.1.ebuild
new file mode 100644
index 000000000000..56309b0f665b
--- /dev/null
+++ b/x11-base/xwayland/xwayland-23.2.1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/xserver.git"
+ inherit git-r3
+else
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/xserver/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Standalone X server running under Wayland"
+HOMEPAGE="https://wayland.freedesktop.org/xserver.html"
+
+IUSE="libei selinux video_cards_nvidia unwind xcsecurity"
+
+LICENSE="MIT"
+SLOT="0"
+
+COMMON_DEPEND="
+ dev-libs/libbsd
+ dev-libs/openssl:=
+ >=dev-libs/wayland-1.21.0
+ >=dev-libs/wayland-protocols-1.30
+ media-fonts/font-util
+ >=media-libs/libepoxy-1.5.4[X,egl(+)]
+ media-libs/libglvnd[X]
+ >=media-libs/mesa-21.1[X(+),egl(+),gbm(+)]
+ >=x11-libs/libdrm-2.4.109
+ >=x11-libs/libXau-1.0.4
+ x11-libs/libxcvt
+ >=x11-libs/libXdmcp-1.0.2
+ >=x11-libs/libXfont2-2.0.1
+ x11-libs/libxkbfile
+ >=x11-libs/libxshmfence-1.1
+ >=x11-libs/pixman-0.27.2
+ >=x11-misc/xkeyboard-config-2.4.1-r3
+
+ libei? ( dev-libs/libei )
+ unwind? ( sys-libs/libunwind )
+ video_cards_nvidia? ( gui-libs/egl-wayland )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ >=x11-base/xorg-proto-2022.2
+ >=x11-libs/xtrans-1.3.5
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ x11-apps/xkbcomp
+ !<=x11-base/xorg-server-1.20.11
+
+ libei? ( >=sys-apps/xdg-desktop-portal-1.18.0 )
+ selinux? ( sec-policy/selinux-xserver )
+"
+BDEPEND="
+ sys-devel/flex
+ dev-util/wayland-scanner
+"
+
+PATCHES=(
+ "${FILESDIR}"/xwayland-drop-redundantly-installed-files.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use selinux xselinux)
+ $(meson_use unwind libunwind)
+ $(meson_use xcsecurity)
+ $(meson_use video_cards_nvidia xwayland_eglstream)
+ -Ddpms=true
+ -Ddri3=true
+ -Ddrm=true
+ -Ddtrace=false
+ -Dglamor=true
+ -Dglx=true
+ -Dipv6=true
+ -Dsecure-rpc=false
+ -Dscreensaver=true
+ -Dsha1=libcrypto
+ -Dxace=true
+ -Dxdmcp=true
+ -Dxinerama=true
+ -Dxvfb=true
+ -Dxv=true
+ -Dxwayland-path="${EPREFIX}"/usr/bin
+ -Dlibdecor=false
+ -Ddocs=false
+ -Ddevel-docs=false
+ -Ddocs-pdf=false
+ )
+
+ if use libei; then
+ emesonargs+=( -Dxwayland_ei=portal )
+ else
+ emesonargs+=( -Dxwayland_ei=false )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ dosym ../bin/Xwayland /usr/libexec/Xwayland
+
+ meson_src_install
+}
diff --git a/x11-base/xwayland/xwayland-9999.ebuild b/x11-base/xwayland/xwayland-9999.ebuild
index 738f4ae7b687..23efd8ee8752 100644
--- a/x11-base/xwayland/xwayland-9999.ebuild
+++ b/x11-base/xwayland/xwayland-9999.ebuild
@@ -16,7 +16,7 @@ fi
DESCRIPTION="Standalone X server running under Wayland"
HOMEPAGE="https://wayland.freedesktop.org/xserver.html"
-IUSE="selinux video_cards_nvidia unwind xcsecurity"
+IUSE="libei selinux video_cards_nvidia unwind xcsecurity"
LICENSE="MIT"
SLOT="0"
@@ -40,6 +40,7 @@ COMMON_DEPEND="
>=x11-libs/pixman-0.27.2
>=x11-misc/xkeyboard-config-2.4.1-r3
+ libei? ( dev-libs/libei )
unwind? ( sys-libs/libunwind )
video_cards_nvidia? ( gui-libs/egl-wayland )
"
@@ -52,6 +53,8 @@ RDEPEND="
${COMMON_DEPEND}
x11-apps/xkbcomp
!<=x11-base/xorg-server-1.20.11
+
+ libei? ( >=sys-apps/xdg-desktop-portal-1.18.0 )
selinux? ( sec-policy/selinux-xserver )
"
BDEPEND="
@@ -82,7 +85,6 @@ src_configure() {
-Dxace=true
-Dxdmcp=true
-Dxinerama=true
- -Dxwayland_ei=false
-Dxvfb=true
-Dxv=true
-Dxwayland-path="${EPREFIX}"/usr/bin
@@ -96,6 +98,12 @@ src_configure() {
-Dxwayland=true
)
+ if use libei; then
+ emesonargs+=( -Dxwayland_ei=portal )
+ else
+ emesonargs+=( -Dxwayland_ei=false )
+ fi
+
meson_src_configure
}