summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-input-evdev/xf86-input-evdev-2.9.2.ebuild')
-rw-r--r--x11-drivers/xf86-input-evdev/xf86-input-evdev-2.9.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.9.2.ebuild b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.9.2.ebuild
new file mode 100644
index 000000000000..141404143932
--- /dev/null
+++ b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.9.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit linux-info xorg-2
+
+DESCRIPTION="Generic Linux input driver"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-base/xorg-server-1.12[udev]
+ dev-libs/libevdev
+ sys-libs/mtdev"
+DEPEND="${RDEPEND}
+ >=x11-proto/inputproto-2.1.99.3
+ >=sys-kernel/linux-headers-2.6"
+
+pkg_pretend() {
+ if use kernel_linux ; then
+ CONFIG_CHECK="~INPUT_EVDEV"
+ fi
+ check_extra_config
+}