summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.1.0-r1.ebuild')
-rw-r--r--x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.1.0-r1.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.1.0-r1.ebuild b/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.1.0-r1.ebuild
index 5729c0d5e63d..2e0a13029688 100644
--- a/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.1.0-r1.ebuild
+++ b/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.1.0-r1.ebuild
@@ -1,30 +1,29 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit udev xorg-2
+inherit udev xorg-3
DESCRIPTION="VMWare mouse input driver"
-IUSE=""
+
KEYWORDS="amd64 x86"
RDEPEND=""
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-pkg_setup() {
- XORG_CONFIGURE_OPTIONS=(
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
--with-hal-bin-dir=/punt
--with-hal-callouts-dir=/punt
--with-hal-fdi-dir=/punt
--with-udev-rules-dir=$(get_udevdir)/rules.d
)
-
- xorg-2_pkg_setup
+ xorg-3_src_configure
}
src_install() {
- xorg-2_src_install
- rm -rf "${ED}"/punt
+ xorg-3_src_install
+ rm -r "${ED}"/punt || die
}