summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-video-rendition')
-rw-r--r--x11-drivers/xf86-video-rendition/Manifest1
-rw-r--r--x11-drivers/xf86-video-rendition/files/xf86-video-rendition-4.2.5-remove-mibstore_h.patch35
-rw-r--r--x11-drivers/xf86-video-rendition/metadata.xml5
-rw-r--r--x11-drivers/xf86-video-rendition/xf86-video-rendition-4.2.5-r1.ebuild17
4 files changed, 58 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-rendition/Manifest b/x11-drivers/xf86-video-rendition/Manifest
new file mode 100644
index 000000000000..ba8dcd6e7786
--- /dev/null
+++ b/x11-drivers/xf86-video-rendition/Manifest
@@ -0,0 +1 @@
+DIST xf86-video-rendition-4.2.5.tar.bz2 356351 SHA256 39b5569338237de6e17b2a2c6be73ac6c405ee596079c41a7028cfd6e54134cb SHA512 203529e2a9c917362ac7c9b4247a9a0a4a7e1911bd022a26b00f467ec4cfd9ce742465aba29618cbfaa5ac5ff0b43e5a54f651e45e81aa950776685e4f74ba72 WHIRLPOOL f617c3ea75537fab46f1d7aaf11d7d0b2291d341a57cf15ca3e992abfa1ab280c5354b04f2cd3791d46a9e8e67c09345d02b3a039e864d6eff8ab99efeac79c0
diff --git a/x11-drivers/xf86-video-rendition/files/xf86-video-rendition-4.2.5-remove-mibstore_h.patch b/x11-drivers/xf86-video-rendition/files/xf86-video-rendition-4.2.5-remove-mibstore_h.patch
new file mode 100644
index 000000000000..77c4d34dea0a
--- /dev/null
+++ b/x11-drivers/xf86-video-rendition/files/xf86-video-rendition-4.2.5-remove-mibstore_h.patch
@@ -0,0 +1,35 @@
+From 3a3ee1c45e54a808947cc26ca11f0a5299571053 Mon Sep 17 00:00:00 2001
+From: Adam Jackson <ajax@redhat.com>
+Date: Tue, 25 Sep 2012 12:54:50 +0000
+Subject: Remove mibstore.h
+
+Signed-off-by: Adam Jackson <ajax@redhat.com>
+---
+diff --git a/src/rendition.c b/src/rendition.c
+index 7c74f76..888bb4a 100644
+--- a/src/rendition.c
++++ b/src/rendition.c
+@@ -1173,7 +1173,6 @@ renditionScreenInit(SCREEN_INIT_ARGS_DECL)
+ fbPictureInit (pScreen, 0, 0);
+
+ xf86SetBlackWhitePixels(pScreen);
+- miInitializeBackingStore(pScreen);
+
+ /*********************************************************/
+ /* The actual setup of the driver-specific code */
+diff --git a/src/rendition.h b/src/rendition.h
+index f7f13d4..297117e 100644
+--- a/src/rendition.h
++++ b/src/rendition.h
+@@ -28,9 +28,6 @@
+ /* All drivers initialising the SW cursor need this */
+ #include "mipointer.h"
+
+-/* All drivers implementing backing store need this */
+-#include "mibstore.h"
+-
+ /* All drivers using the mi colormap manipulation need this */
+ #include "micmap.h"
+
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/x11-drivers/xf86-video-rendition/metadata.xml b/x11-drivers/xf86-video-rendition/metadata.xml
new file mode 100644
index 000000000000..01c4c004e735
--- /dev/null
+++ b/x11-drivers/xf86-video-rendition/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>
diff --git a/x11-drivers/xf86-video-rendition/xf86-video-rendition-4.2.5-r1.ebuild b/x11-drivers/xf86-video-rendition/xf86-video-rendition-4.2.5-r1.ebuild
new file mode 100644
index 000000000000..0985976ae35d
--- /dev/null
+++ b/x11-drivers/xf86-video-rendition/xf86-video-rendition-4.2.5-r1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xorg-2
+
+DESCRIPTION="Rendition video driver"
+KEYWORDS="alpha amd64 ia64 x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=x11-base/xorg-server-1.0.99"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-remove-mibstore_h.patch
+)