summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/c++-gtk-utils/c++-gtk-utils-2.0.28.ebuild')
-rw-r--r--x11-libs/c++-gtk-utils/c++-gtk-utils-2.0.28.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-libs/c++-gtk-utils/c++-gtk-utils-2.0.28.ebuild b/x11-libs/c++-gtk-utils/c++-gtk-utils-2.0.28.ebuild
new file mode 100644
index 000000000000..17ec71a2966c
--- /dev/null
+++ b/x11-libs/c++-gtk-utils/c++-gtk-utils-2.0.28.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="A library containing a number of classes and functions for programming GTK+ programs using C++"
+HOMEPAGE="http://cxx-gtk-utils.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN/++/xx}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+gtk nls static-libs"
+SLOT="3"
+
+RDEPEND="
+ >=dev-libs/glib-2.26
+ gtk? ( x11-libs/gtk+:3 )
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+DOCS=( ChangeLog )
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with gtk) \
+ $(use_enable static-libs static) \
+ --docdir=/usr/share/doc/${PF} \
+ --htmldir=/usr/share/doc/${PF}/html \
+ --without-guile
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}