summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/gl2ps/files/gl2ps-1.3.6-CMakeLists.patch')
-rw-r--r--x11-libs/gl2ps/files/gl2ps-1.3.6-CMakeLists.patch61
1 files changed, 61 insertions, 0 deletions
diff --git a/x11-libs/gl2ps/files/gl2ps-1.3.6-CMakeLists.patch b/x11-libs/gl2ps/files/gl2ps-1.3.6-CMakeLists.patch
new file mode 100644
index 000000000000..53e0fba7e493
--- /dev/null
+++ b/x11-libs/gl2ps/files/gl2ps-1.3.6-CMakeLists.patch
@@ -0,0 +1,61 @@
+--- CMakeLists.txt.orig 2011-08-14 18:15:31.000000000 +0100
++++ CMakeLists.txt 2011-11-27 05:25:50.000000000 +0000
+@@ -46,6 +46,7 @@
+
+ option(ENABLE_ZLIB "Enable compression using ZLIB" ON)
+ option(ENABLE_PNG "Enable PNG support" ON)
++option(ENABLE_DOC "Enable documentation" OFF)
+
+ set(GL2PS_MAJOR_VERSION 1)
+ set(GL2PS_MINOR_VERSION 3)
+@@ -103,8 +104,6 @@
+ include_directories(${EXTERNAL_INCLUDES})
+
+ if(OPENGL_FOUND)
+- add_library(lib STATIC gl2ps.c gl2ps.h)
+- set_target_properties(lib PROPERTIES OUTPUT_NAME gl2ps)
+
+ add_library(shared SHARED gl2ps.c gl2ps.h)
+ target_link_libraries(shared ${EXTERNAL_LIBRARIES})
+@@ -116,29 +115,22 @@
+ set_target_properties(shared PROPERTIES COMPILE_FLAGS "-DGL2PSDLL -DGL2PSDLL_EXPORTS")
+ endif(MSVC)
+
+- install(TARGETS lib shared DESTINATION lib)
++ install(TARGETS shared DESTINATION lib${LIB_SUFFIX})
+ endif(OPENGL_FOUND)
+
+ if(WIN32)
+ set(GL2PS_DOC .)
+ else(WIN32)
+- set(GL2PS_DOC share/doc/gl2ps)
++ set(GL2PS_DOC share/doc/gl2ps-${GL2PS_VERSION})
+ endif(WIN32)
+
+ install(FILES gl2ps.h DESTINATION include)
+ install(FILES ${CMAKE_SOURCE_DIR}/README.txt DESTINATION ${GL2PS_DOC})
+-install(FILES ${CMAKE_SOURCE_DIR}/COPYING.LGPL DESTINATION ${GL2PS_DOC})
+-install(FILES ${CMAKE_SOURCE_DIR}/COPYING.GL2PS DESTINATION ${GL2PS_DOC})
+ install(FILES ${CMAKE_SOURCE_DIR}/gl2psTest.c DESTINATION ${GL2PS_DOC})
++install(FILES ${CMAKE_SOURCE_DIR}/TODO.txt DESTINATION ${GL2PS_DOC})
+ install(FILES ${CMAKE_SOURCE_DIR}/gl2psTestSimple.c DESTINATION ${GL2PS_DOC})
+
+-if(GLUT_FOUND)
+- add_executable(gl2psTest WIN32 gl2psTest.c)
+- target_link_libraries(gl2psTest lib ${EXTERNAL_LIBRARIES})
+- add_executable(gl2psTestSimple WIN32 gl2psTestSimple.c)
+- target_link_libraries(gl2psTestSimple lib ${EXTERNAL_LIBRARIES})
+-endif(GLUT_FOUND)
+-
++if(ENABLE_DOC)
+ find_package(LATEX)
+ if(PDFLATEX_COMPILER)
+ add_custom_command(OUTPUT gl2ps.pdf DEPENDS gl2ps.tex
+@@ -157,6 +149,7 @@
+ add_custom_target(html DEPENDS gl2ps.html)
+ endif(TTH)
+ endif(PDFLATEX_COMPILER)
++endif(ENABLE_DOC)
+
+ set(CPACK_PACKAGE_VENDOR "Christophe Geuzaine")
+ set(CPACK_PACKAGE_VERSION_MAJOR ${GL2PS_MAJOR_VERSION})