summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/gtk+/gtk+-2.24.33-r3.ebuild')
-rw-r--r--x11-libs/gtk+/gtk+-2.24.33-r3.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/x11-libs/gtk+/gtk+-2.24.33-r3.ebuild b/x11-libs/gtk+/gtk+-2.24.33-r3.ebuild
index b28a310466f8..be2fa7edc852 100644
--- a/x11-libs/gtk+/gtk+-2.24.33-r3.ebuild
+++ b/x11-libs/gtk+/gtk+-2.24.33-r3.ebuild
@@ -256,13 +256,13 @@ pkg_postinst() {
set_gtk2_confdir
- if [ -e "${EROOT}/etc/gtk-2.0/gtk.immodules" ]; then
+ if [[ -e "${EROOT}/etc/gtk-2.0/gtk.immodules" ]]; then
elog "File /etc/gtk-2.0/gtk.immodules has been moved to \$CHOST"
elog "aware location. Removing deprecated file."
rm -f "${EROOT}/etc/gtk-2.0/gtk.immodules"
fi
- if [ -e "${EROOT}${GTK2_CONFDIR}/gtk.immodules" ]; then
+ if [[ -e "${EROOT}${GTK2_CONFDIR}/gtk.immodules" ]]; then
elog "File /etc/gtk-2.0/gtk.immodules has been moved to"
elog "${EROOT}/usr/$(get_libdir)/gtk-2.0/2.10.0/immodules.cache"
elog "Removing deprecated file."
@@ -270,20 +270,20 @@ pkg_postinst() {
fi
# pixbufs are now handled by x11-libs/gdk-pixbuf
- if [ -e "${EROOT}${GTK2_CONFDIR}/gdk-pixbuf.loaders" ]; then
+ if [[ -e "${EROOT}${GTK2_CONFDIR}/gdk-pixbuf.loaders" ]]; then
elog "File ${EROOT}${GTK2_CONFDIR}/gdk-pixbuf.loaders is now handled by x11-libs/gdk-pixbuf"
elog "Removing deprecated file."
rm -f "${EROOT}${GTK2_CONFDIR}/gdk-pixbuf.loaders"
fi
# two checks needed since we dropped multilib conditional
- if [ -e "${EROOT}/etc/gtk-2.0/gdk-pixbuf.loaders" ]; then
+ if [[ -e "${EROOT}/etc/gtk-2.0/gdk-pixbuf.loaders" ]]; then
elog "File ${EROOT}/etc/gtk-2.0/gdk-pixbuf.loaders is now handled by x11-libs/gdk-pixbuf"
elog "Removing deprecated file."
rm -f "${EROOT}/etc/gtk-2.0/gdk-pixbuf.loaders"
fi
- if [ -e "${EROOT}"/usr/lib/gtk-2.0/2.[^1]* ]; then
+ if [[ -e "${EROOT}"/usr/lib/gtk-2.0/2.[^1]* ]]; then
elog "You need to rebuild ebuilds that installed into" "${EROOT}"/usr/lib/gtk-2.0/2.[^1]*
elog "to do that you can use qfile from portage-utils:"
elog "emerge -va1 \$(qfile -qC ${EPREFIX}/usr/lib/gtk-2.0/2.[^1]*)"