summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libxcb/libxcb-1.9.1.ebuild')
-rw-r--r--x11-libs/libxcb/libxcb-1.9.1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/x11-libs/libxcb/libxcb-1.9.1.ebuild b/x11-libs/libxcb/libxcb-1.9.1.ebuild
deleted file mode 100644
index 91d16ecbc6b5..000000000000
--- a/x11-libs/libxcb/libxcb-1.9.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE=xml
-
-XORG_DOC=doc
-XORG_MULTILIB=yes
-inherit python-single-r1 xorg-2
-
-DESCRIPTION="X C-language Bindings library"
-HOMEPAGE="https://xcb.freedesktop.org/"
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/libxcb"
-[[ ${PV} != 9999* ]] && \
- SRC_URI="https://xcb.freedesktop.org/dist/${P}.tar.bz2"
-
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="selinux xkb"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND=">=dev-libs/libpthread-stubs-0.3-r1[${MULTILIB_USEDEP}]
- >=x11-libs/libXau-1.0.7-r1[${MULTILIB_USEDEP}]
- >=x11-libs/libXdmcp-1.1.1-r1[${MULTILIB_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-lang/python[xml]
- dev-libs/libxslt
- >=x11-proto/xcb-proto-1.8-r3[${MULTILIB_USEDEP},${PYTHON_USEDEP}]
- ${PYTHON_DEPS}"
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_configure() {
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable doc build-docs)
- $(use_enable selinux)
- $(use_enable xkb)
- --enable-xinput
- )
- xorg-2_src_configure
-}