summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libyui-ncurses')
-rw-r--r--x11-libs/libyui-ncurses/Manifest1
-rw-r--r--x11-libs/libyui-ncurses/files/libyui-ncurses-2.46.4-tinfo.patch21
-rw-r--r--x11-libs/libyui-ncurses/libyui-ncurses-2.46.4.ebuild49
-rw-r--r--x11-libs/libyui-ncurses/metadata.xml14
4 files changed, 85 insertions, 0 deletions
diff --git a/x11-libs/libyui-ncurses/Manifest b/x11-libs/libyui-ncurses/Manifest
new file mode 100644
index 000000000000..a6cf188e5346
--- /dev/null
+++ b/x11-libs/libyui-ncurses/Manifest
@@ -0,0 +1 @@
+DIST libyui-ncurses-2.46.4.tar.gz 181155 SHA256 3b2ec425277f5d4658c3318339076b72b9ee5e229569014ad69fd99948d8dec9 SHA512 9e03aa29ea7660c20d4ce36b7ebcac02af152185af3e91650d0d59379d3b2779515aa0b2325155a4eaaa02a1addc2ac25cf8a13d0e67a32fe94191da06c1b483 WHIRLPOOL fac47b00f9a8fe7c0293dd89f5cc6949104d4ee910487ef55cf0f323724d8079da5b880c8f8f99ba298fa385bc866a3377d21c198e52215d4b22d0d1df72d2f7
diff --git a/x11-libs/libyui-ncurses/files/libyui-ncurses-2.46.4-tinfo.patch b/x11-libs/libyui-ncurses/files/libyui-ncurses-2.46.4-tinfo.patch
new file mode 100644
index 000000000000..b69aafe797b1
--- /dev/null
+++ b/x11-libs/libyui-ncurses/files/libyui-ncurses-2.46.4-tinfo.patch
@@ -0,0 +1,21 @@
+Fixes building with sys-libs/ncurses[tinfo]
+
+--- cmake/Modules/FindCurses6.cmake.orig 2014-09-25 16:32:20.000000000 +0400
++++ cmake/Modules/FindCurses6.cmake 2014-09-25 16:33:16.000000000 +0400
+@@ -11,11 +11,12 @@
+ FIND_LIBRARY(CURSES6_TINFO_LIBRARY NAMES tinfo PATHS ${path}/ncurses6 ${path} NO_DEFAULT_PATH)
+ ENDFOREACH()
+
+-SET(CURSES6_LIBRARIES ${CURSES6_NCURSESW_LIBRARY} ${CURSES6_PANELW_LIBRARY})
+ # tinfo is optional (in 12.1 is not there)
+-IF(${CURSES6_TINFO_LIBRARY})
+- SET(CURSES6_LIBRARIES "${CURSES6_LIBRARIES} ${CURSES6_TINFO_LIBRARY}")
+-ENDIF(${CURSES6_TINFO_LIBRARY})
++IF(NOT ${CURSES6_TINFO_LIBRARY} STREQUAL "CURSES6_TINFO_LIBRARY-NOTFOUND")
++ SET(CURSES6_LIBRARIES ${CURSES6_NCURSESW_LIBRARY} ${CURSES6_PANELW_LIBRARY} ${CURSES6_TINFO_LIBRARY})
++ELSE()
++ SET(CURSES6_LIBRARIES ${CURSES6_NCURSESW_LIBRARY} ${CURSES6_PANELW_LIBRARY})
++ENDIF()
+
+ FIND_PATH(CURSES6_INCLUDE_DIR ncurses.h PATH_SUFFIXES ncurses6)
+
diff --git a/x11-libs/libyui-ncurses/libyui-ncurses-2.46.4.ebuild b/x11-libs/libyui-ncurses/libyui-ncurses-2.46.4.ebuild
new file mode 100644
index 000000000000..50385b22ea55
--- /dev/null
+++ b/x11-libs/libyui-ncurses/libyui-ncurses-2.46.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="UI abstraction library - ncurses plugin"
+HOMEPAGE="https://github.com/libyui/libyui-ncurses"
+SRC_URI="https://github.com/libyui/${PN}/archive/${PN}/master/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/6"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="static-libs"
+
+RDEPEND="sys-libs/ncurses
+ x11-libs/libyui:${SLOT}
+"
+# Only Boost headers are needed
+DEPEND="${RDEPEND}
+ dev-libs/boost"
+
+PATCHES=( "${FILESDIR}/${P}-tinfo.patch" )
+
+S="${WORKDIR}/${PN}-${PN}-master-${PV}"
+
+src_prepare() {
+ cp "${EPREFIX}/usr/share/libyui/buildtools/CMakeLists.common" CMakeLists.txt || die
+
+ # TODO: set proper docs deps and USE flag for building them
+ sed -i -e '/SET_AUTODOCS/d' CMakeLists.txt || die 'sed on CMakeLists.txt failed'
+ sed -i -e 's/src examples/src/' PROJECTINFO.cmake || die 'sed on PROJECTINFO.cmake failed'
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_EXAMPLES=OFF
+ -DENABLE_WERROR=OFF
+ -DDOC_DIR="${EPREFIX}/usr/share/doc/${P}"
+ -DRESPECT_FLAGS=ON
+ $(cmake-utils_use_enable static-libs STATIC)
+ )
+ cmake-utils_src_configure
+}
diff --git a/x11-libs/libyui-ncurses/metadata.xml b/x11-libs/libyui-ncurses/metadata.xml
new file mode 100644
index 000000000000..3695e1541170
--- /dev/null
+++ b/x11-libs/libyui-ncurses/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>miska@gentoo.org</email>
+ <name>Michal Hrušecký</name>
+ </maintainer>
+ <longdescription lang="en">
+ncurses plugin for libyui -- YaST2 user interface engine that provides the abstraction from graphical user interfaces (Qt, Gtk) and text based user interfaces (ncurses).
+</longdescription>
+ <upstream>
+ <remote-id type="github">libyui/libyui-ncurses</remote-id>
+ </upstream>
+</pkgmetadata>