summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/pango/pango-1.40.4.ebuild')
-rw-r--r--x11-libs/pango/pango-1.40.4.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/x11-libs/pango/pango-1.40.4.ebuild b/x11-libs/pango/pango-1.40.4.ebuild
deleted file mode 100644
index f0680857c0f4..000000000000
--- a/x11-libs/pango/pango-1.40.4.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-GNOME2_LA_PUNT="yes"
-
-inherit gnome2 multilib-minimal toolchain-funcs
-
-DESCRIPTION="Internationalized text layout and rendering library"
-HOMEPAGE="http://www.pango.org/"
-
-LICENSE="LGPL-2+ FTL"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-
-IUSE="X +introspection test"
-
-RDEPEND="
- >=media-libs/harfbuzz-0.9.30:=[glib(+),truetype(+),${MULTILIB_USEDEP}]
- >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
- >=media-libs/fontconfig-2.10.92:1.0=[${MULTILIB_USEDEP}]
- >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}]
- >=x11-libs/cairo-1.12.14-r4:=[X?,${MULTILIB_USEDEP}]
- introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
- X? (
- >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
- >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
- >=x11-libs/libXft-2.3.1-r1[${MULTILIB_USEDEP}]
- )
-"
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.20
- virtual/pkgconfig[${MULTILIB_USEDEP}]
- test? ( media-fonts/cantarell )
- X? ( >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}] )
- !<=sys-devel/autoconf-2.63:2.5
-"
-
-src_prepare() {
- default
- # This should be updated if next release fails to pre-generate the manpage as well, or src_prepare removed if is properly generated
- # https://bugzilla.gnome.org/show_bug.cgi?id=779704
- cp -v "${FILESDIR}"/${PV}-pango-view.1.in "${S}/pango-view/pango-view.1.in" || die
-}
-
-multilib_src_configure() {
- tc-export CXX
-
- ECONF_SOURCE=${S} \
- gnome2_src_configure \
- --with-cairo \
- $(multilib_native_use_enable introspection) \
- $(use_with X xft) \
- "$(usex X --x-includes="${EPREFIX}/usr/include" "")" \
- "$(usex X --x-libraries="${EPREFIX}/usr/$(get_libdir)" "")"
-
- if multilib_is_native_abi; then
- ln -s "${S}"/docs/html docs/html || die
- fi
-}
-
-multilib_src_install() {
- gnome2_src_install
-}