summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/qtermwidget/qtermwidget-1.4.0.ebuild')
-rw-r--r--x11-libs/qtermwidget/qtermwidget-1.4.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-libs/qtermwidget/qtermwidget-1.4.0.ebuild b/x11-libs/qtermwidget/qtermwidget-1.4.0.ebuild
new file mode 100644
index 000000000000..ff5db81487f3
--- /dev/null
+++ b/x11-libs/qtermwidget/qtermwidget-1.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt terminal emulator widget"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
+fi
+
+LICENSE="BSD GPL-2 LGPL-2+"
+SLOT="0/${PV}"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.13.0
+"
+DEPEND="
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+"
+RDEPEND="${DEPEND}"