summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/wxGTK')
-rw-r--r--x11-libs/wxGTK/wxGTK-3.0.4-r5.ebuild7
-rw-r--r--x11-libs/wxGTK/wxGTK-3.0.5.1-r1.ebuild7
-rw-r--r--x11-libs/wxGTK/wxGTK-3.2.1.ebuild7
-rw-r--r--x11-libs/wxGTK/wxGTK-3.2.2.1-r1.ebuild7
-rw-r--r--x11-libs/wxGTK/wxGTK-3.2.2.1-r2.ebuild7
-rw-r--r--x11-libs/wxGTK/wxGTK-3.2.2.1-r3.ebuild5
6 files changed, 29 insertions, 11 deletions
diff --git a/x11-libs/wxGTK/wxGTK-3.0.4-r5.ebuild b/x11-libs/wxGTK/wxGTK-3.0.4-r5.ebuild
index 5113d156cb72..597919bb53e1 100644
--- a/x11-libs/wxGTK/wxGTK-3.0.4-r5.ebuild
+++ b/x11-libs/wxGTK/wxGTK-3.0.4-r5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit multilib-minimal
+inherit multilib-minimal flag-o-matic
DESCRIPTION="GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit"
HOMEPAGE="https://wxwidgets.org/"
@@ -53,6 +53,9 @@ PATCHES=(
)
multilib_src_configure() {
+ # Workaround for bug #915154
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
local myconf=(
# X independent options
--with-zlib=sys
diff --git a/x11-libs/wxGTK/wxGTK-3.0.5.1-r1.ebuild b/x11-libs/wxGTK/wxGTK-3.0.5.1-r1.ebuild
index d679c0cb319d..6b61006effd7 100644
--- a/x11-libs/wxGTK/wxGTK-3.0.5.1-r1.ebuild
+++ b/x11-libs/wxGTK/wxGTK-3.0.5.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit multilib-minimal
+inherit multilib-minimal flag-o-matic
WXSUBVERSION=${PV}-gtk3 # 3.0.5.1-gtk3
WXVERSION=${WXSUBVERSION%.*} # 3.0.5
@@ -92,6 +92,9 @@ src_prepare() {
}
multilib_src_configure() {
+ # Workaround for bug #915154
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
# X independent options
local myeconfargs=(
--with-zlib=sys
diff --git a/x11-libs/wxGTK/wxGTK-3.2.1.ebuild b/x11-libs/wxGTK/wxGTK-3.2.1.ebuild
index 4f7a1685e919..4139f68a76de 100644
--- a/x11-libs/wxGTK/wxGTK-3.2.1.ebuild
+++ b/x11-libs/wxGTK/wxGTK-3.2.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit multilib-minimal
+inherit multilib-minimal flag-o-matic
WXSUBVERSION=${PV}-gtk3 # 3.2.1-gtk3
WXVERSION=${PV} # 3.2.1
@@ -124,6 +124,9 @@ src_prepare() {
}
multilib_src_configure() {
+ # Workaround for bug #915154
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
# X independent options
local myeconfargs=(
--with-zlib=sys
diff --git a/x11-libs/wxGTK/wxGTK-3.2.2.1-r1.ebuild b/x11-libs/wxGTK/wxGTK-3.2.2.1-r1.ebuild
index 517f06f625d9..e8676bf92185 100644
--- a/x11-libs/wxGTK/wxGTK-3.2.2.1-r1.ebuild
+++ b/x11-libs/wxGTK/wxGTK-3.2.2.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit multilib-minimal
+inherit multilib-minimal flag-o-matic
WXSUBVERSION="${PV}-gtk3" # 3.2.1-gtk3
WXVERSION="$(ver_cut 1-3)" # 3.2.1
@@ -126,6 +126,9 @@ src_prepare() {
}
multilib_src_configure() {
+ # Workaround for bug #915154
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
# X independent options
local myeconfargs=(
--with-zlib=sys
diff --git a/x11-libs/wxGTK/wxGTK-3.2.2.1-r2.ebuild b/x11-libs/wxGTK/wxGTK-3.2.2.1-r2.ebuild
index 94c449eddee9..2c676c2e229e 100644
--- a/x11-libs/wxGTK/wxGTK-3.2.2.1-r2.ebuild
+++ b/x11-libs/wxGTK/wxGTK-3.2.2.1-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit multilib-minimal
+inherit multilib-minimal flag-o-matic
WXSUBVERSION="${PV}-gtk3" # 3.2.1-gtk3
WXVERSION="$(ver_cut 1-3)" # 3.2.1
@@ -126,6 +126,9 @@ src_prepare() {
}
multilib_src_configure() {
+ # Workaround for bug #915154
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
# X independent options
local myeconfargs=(
--with-zlib=sys
diff --git a/x11-libs/wxGTK/wxGTK-3.2.2.1-r3.ebuild b/x11-libs/wxGTK/wxGTK-3.2.2.1-r3.ebuild
index 80348ec9e55a..b6f07556613f 100644
--- a/x11-libs/wxGTK/wxGTK-3.2.2.1-r3.ebuild
+++ b/x11-libs/wxGTK/wxGTK-3.2.2.1-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit multilib-minimal
+inherit multilib-minimal flag-o-matic
WXSUBVERSION="${PV}-gtk3" # 3.2.1-gtk3
WXVERSION="$(ver_cut 1-3)" # 3.2.1
@@ -126,6 +126,9 @@ src_prepare() {
}
multilib_src_configure() {
+ # Workaround for bug #915154
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
# X independent options
local myeconfargs=(
--with-zlib=sys