summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/wxGTK')
-rw-r--r--x11-libs/wxGTK/Manifest2
-rw-r--r--x11-libs/wxGTK/files/wxGTK-3.2.1-configure-tests.patch19
-rw-r--r--x11-libs/wxGTK/files/wxGTK-3.2.1-gtk3-translation-domain.patch12
-rw-r--r--x11-libs/wxGTK/wxGTK-3.2.1.ebuild177
4 files changed, 210 insertions, 0 deletions
diff --git a/x11-libs/wxGTK/Manifest b/x11-libs/wxGTK/Manifest
index 4bb5a247f623..9786d1999568 100644
--- a/x11-libs/wxGTK/Manifest
+++ b/x11-libs/wxGTK/Manifest
@@ -4,3 +4,5 @@ DIST wxWidgets-3.0.4-docs-html.tar.bz2 24122986 BLAKE2B ffd38d50e6cb44077f346597
DIST wxWidgets-3.0.4.tar.bz2 20204622 BLAKE2B 97b9f3f44f080104cae290bc3e162b51ce27a96fb22b191d52f30db1f1dc7951defcc220afc4dcb8417cfe23490762c2a25f62164ac21809f73ccf442dd19347 SHA512 c9e6b35d541a99921c54cfdac260843f574f146b27f924a7a0fca5007344fa99865a96ded95e6802329ad9221b4880d62b92277a1b4c1ce71420acb672ad9158
DIST wxWidgets-3.0.5-docs-html.tar.bz2 23844256 BLAKE2B f5b5bef129302ae1ded7a651e652b127ad9d548a00a498f06a4d4f868dc3bc33411ded2602c04c8329e927550d032bdbe633c2c7d1a7f89265874685d3cb3d9b SHA512 f839e67660f2b08aa28d1596a3b7af2c35f7c2c0505c6e6d45888845397212b3dd71c8d34115321e9a4347b9d92a0ce767bb76defd14c172e51c2a3df96cc3ac
DIST wxWidgets-3.0.5.1.tar.bz2 19739206 BLAKE2B da270cb8e4fc22b8d892ba80fbb4cc71578f642ca07102006f914a80331a254e746de6c91e61b585c0b1ab3abadd17d80a0eaa3efd48a3d412cf7202101abc7a SHA512 0a789fc5e71d414e43f75b5c16076fe8b1bcd7671be0770e4269dcef66d830c1bc74e183f49db270b928862f13472666c283fe2aa98b9006681722e06100725d
+DIST wxWidgets-3.2.1-docs-html.tar.bz2 18213181 BLAKE2B 2df358f0dda08e2a790efed2838c3298bb14e68d778a6cf2ad5630a1f166800228887aa7f0eb3998e155f8f4329007a605f8e33597aa502f72a7b8273cb850f5 SHA512 ab5263104a93622ebc4c703ea6b91a0a2cf0f0a090fb81786f0187fdacd2374cbc6e317f579a2da343719234ddfb29ae7449a26c9d5e35650a723a2246d92c5e
+DIST wxWidgets-3.2.1.tar.bz2 27266651 BLAKE2B f1eda8795f1cba10903e9e3ed6f683520a707ea40d2bb5a0d7f53fcb38a31c67c1cf07b8e704f107627ead9a90b1efec68c5986e5420b393b70ea23d305dab64 SHA512 d0294788891014672d8eb4501ae257598972407b53f38471e4f11dd20f517d0145d510c5bce006b09c5d63113fed844bdf6124b3c80453c1d37b402abc89202b
diff --git a/x11-libs/wxGTK/files/wxGTK-3.2.1-configure-tests.patch b/x11-libs/wxGTK/files/wxGTK-3.2.1-configure-tests.patch
new file mode 100644
index 000000000000..fe90b3aab0d9
--- /dev/null
+++ b/x11-libs/wxGTK/files/wxGTK-3.2.1-configure-tests.patch
@@ -0,0 +1,19 @@
+diff --git a/configure b/configure
+index d2acb7d..69ae083 100755
+--- a/configure
++++ b/configure
+@@ -45622,6 +45622,14 @@ $as_echo "yes" >&6; }
+ fi
+ fi
+
++# explicit override to enable or disable tests
++if test "${enable_tests+set}" = set; then
++ SUBDIRS="$SUBDIRS tests"
++fi
++if test "${disable_tests+set}" = set; then
++ SUBDIRS="${SUBDIRS% tests}"
++fi
++
+ for subdir in $SUBDIRS; do
+ if test -d ${srcdir}/${subdir} ; then
+ if test "$wxUSE_GUI" = "yes"; then
diff --git a/x11-libs/wxGTK/files/wxGTK-3.2.1-gtk3-translation-domain.patch b/x11-libs/wxGTK/files/wxGTK-3.2.1-gtk3-translation-domain.patch
new file mode 100644
index 000000000000..9fbb9d8bc064
--- /dev/null
+++ b/x11-libs/wxGTK/files/wxGTK-3.2.1-gtk3-translation-domain.patch
@@ -0,0 +1,12 @@
+Modify AddStdCatalog to use the versioned wxstd32-gtk3.mo.
+--- a/src/common/translation.cpp
++++ b/src/common/translation.cpp
+@@ -1409,7 +1409,7 @@ bool wxTranslations::AddStdCatalog()
+ if ( AddCatalog("wxstd-" wxSTRINGIZE(wxMAJOR_VERSION) "." wxSTRINGIZE(wxMINOR_VERSION)) )
+ return true;
+
+- if ( AddCatalog(wxS("wxstd")) )
++ if ( AddCatalog(wxS("wxstd32-gtk3")) )
+ return true;
+
+ return false;
diff --git a/x11-libs/wxGTK/wxGTK-3.2.1.ebuild b/x11-libs/wxGTK/wxGTK-3.2.1.ebuild
new file mode 100644
index 000000000000..479152cb5f24
--- /dev/null
+++ b/x11-libs/wxGTK/wxGTK-3.2.1.ebuild
@@ -0,0 +1,177 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+WXSUBVERSION=${PV}-gtk3 # 3.2.1-gtk3
+WXVERSION=${PV} # 3.2.1
+WXRELEASE=${WXVERSION%.*}-gtk3 # 3.2-gtk3
+WXRELEASE_NODOT=${WXRELEASE//./} # 32-gtk3
+
+DESCRIPTION="GTK version of wxWidgets, a cross-platform C++ GUI toolkit"
+HOMEPAGE="https://wxwidgets.org/"
+SRC_URI="
+ https://github.com/wxWidgets/wxWidgets/releases/download/v${PV}/wxWidgets-${PV}.tar.bz2
+ https://dev.gentoo.org/~leio/distfiles/wxGTK-3.0.5_p20210214.tar.xz
+ doc? ( https://github.com/wxWidgets/wxWidgets/releases/download/v${PV}/wxWidgets-${PV}-docs-html.tar.bz2 )"
+S="${WORKDIR}/wxWidgets-${PV}"
+
+LICENSE="wxWinLL-3 GPL-2 doc? ( wxWinFDL-3 )"
+SLOT="${WXRELEASE}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+X doc debug gstreamer libnotify opengl pch sdl test tiff webkit"
+REQUIRED_USE="test? ( tiff ) tiff? ( X )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-eselect/eselect-wxwidgets-20131230
+ dev-libs/expat[${MULTILIB_USEDEP}]
+ sdl? ( media-libs/libsdl2[${MULTILIB_USEDEP}] )
+ X? (
+ >=dev-libs/glib-2.22:2[${MULTILIB_USEDEP}]
+ media-libs/libjpeg-turbo:=[${MULTILIB_USEDEP}]
+ media-libs/libpng:0=[${MULTILIB_USEDEP}]
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf[${MULTILIB_USEDEP}]
+ x11-libs/libSM[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]
+ gstreamer? (
+ media-libs/gstreamer:1.0[${MULTILIB_USEDEP}]
+ media-libs/gst-plugins-base:1.0[${MULTILIB_USEDEP}]
+ )
+ libnotify? ( x11-libs/libnotify[${MULTILIB_USEDEP}] )
+ opengl? ( virtual/opengl[${MULTILIB_USEDEP}] )
+ tiff? ( media-libs/tiff:0[${MULTILIB_USEDEP}] )
+ webkit? ( net-libs/webkit-gtk:4 )
+ )"
+DEPEND="${RDEPEND}
+ opengl? ( virtual/glu[${MULTILIB_USEDEP}] )
+ X? ( x11-base/xorg-proto )"
+BDEPEND="
+ test? ( >=dev-util/cppunit-1.8.0 )
+ >=app-eselect/eselect-wxwidgets-20131230
+ virtual/pkgconfig"
+
+PATCHES=(
+ #"${WORKDIR}"/wxGTK-3.0.5_p20210214/
+ "${FILESDIR}"/${P}-gtk3-translation-domain.patch
+ #"${FILESDIR}"/wxGTK-ignore-c++-abi.patch #676878
+ "${FILESDIR}/${P}-configure-tests.patch"
+)
+
+src_prepare() {
+ default
+
+ # Versionating
+ sed -i \
+ -e "s:\(WX_RELEASE = \).*:\1${WXRELEASE}:"\
+ -e "s:\(WX_RELEASE_NODOT = \).*:\1${WXRELEASE_NODOT}:"\
+ -e "s:\(WX_VERSION = \).*:\1${WXVERSION}:"\
+ -e "s:aclocal):aclocal/wxwin${WXRELEASE_NODOT}.m4):" \
+ Makefile.in tests/Makefile.in || die
+
+ sed -i \
+ -e "s:\(WX_RELEASE = \).*:\1${WXRELEASE}:"\
+ utils/wxrc/Makefile.in || die
+
+ sed -i \
+ -e "s:\(WX_VERSION=\).*:\1${WXVERSION}:" \
+ -e "s:\(WX_RELEASE=\).*:\1${WXRELEASE}:" \
+ -e "s:\(WX_SUBVERSION=\).*:\1${WXSUBVERSION}:" \
+ -e '/WX_VERSION_TAG=/ s:${WX_RELEASE}:3.0:' \
+ configure || die
+}
+
+multilib_src_configure() {
+ # X independent options
+ local myeconfargs=(
+ --with-zlib=sys
+ --with-expat=sys
+ --enable-compat30
+ $(use_with sdl)
+
+ # PCHes are unstable and are disabled in-tree where possible
+ # See bug #504204
+ # Commits 8c4774042b7fdfb08e525d8af4b7912f26a2fdce, fb809aeadee57ffa24591e60cfb41aecd4823090
+ $(use_enable pch precomp-headers)
+
+ # Don't hard-code libdir's prefix for wx-config
+ --libdir='${prefix}'/$(get_libdir)
+ )
+
+ # debug in >=2.9
+ # there is no longer separate debug libraries (gtk2ud)
+ # wxDEBUG_LEVEL=1 is the default and we will leave it enabled
+ # wxDEBUG_LEVEL=2 enables assertions that have expensive runtime costs.
+ # apps can disable these features by building w/ -NDEBUG or wxDEBUG_LEVEL_0.
+ # http://docs.wxwidgets.org/3.0/overview_debugging.html
+ # https://groups.google.com/group/wx-dev/browse_thread/thread/c3c7e78d63d7777f/05dee25410052d9c
+ use debug && myeconfargs+=( --enable-debug=max )
+
+ # wxGTK options
+ # --enable-graphics_ctx - needed for webkit, editra
+ # --without-gnomevfs - bug #203389
+ use X && myeconfargs+=(
+ --enable-graphics_ctx
+ --with-gtkprint
+ --enable-gui
+ --with-gtk=3
+ --with-libpng=sys
+ --with-libjpeg=sys
+ --without-gnomevfs
+ $(use_enable gstreamer mediactrl)
+ $(multilib_native_use_enable webkit webview)
+ $(use_with libnotify)
+ $(use_with opengl)
+ $(use_with tiff libtiff sys)
+ $(use_enable test tests)
+ )
+
+ # wxBase options
+ ! use X && myeconfargs+=( --disable-gui )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_test() {
+ emake -C tests
+ (cd tests && ./test) || die
+}
+
+multilib_src_install_all() {
+ cd docs || die
+ dodoc changes.txt readme.txt
+ newdoc base/readme.txt base_readme.txt
+ newdoc gtk/readme.txt gtk_readme.txt
+
+ use doc && HTML_DOCS=( "${WORKDIR}"/wxWidgets-${WXVERSION}-docs-html/. )
+ einstalldocs
+
+ # Unversioned links
+ rm "${ED}"/usr/bin/wx-config || die
+ use X && { rm "${ED}"/usr/bin/wxrc || die; }
+
+ # version bakefile presets
+ pushd "${ED}"/usr/share/bakefile/presets >/dev/null || die
+ local f
+ for f in wx*; do
+ mv "${f}" "${f/wx/wx32gtk3}" || die
+ done
+ popd >/dev/null || die
+}
+
+pkg_postinst() {
+ has_version -b app-eselect/eselect-wxwidgets \
+ && eselect wxwidgets update
+}
+
+pkg_postrm() {
+ has_version -b app-eselect/eselect-wxwidgets \
+ && eselect wxwidgets update
+}