summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/bbcd/bbcd-0.3.1-r5.ebuild')
-rw-r--r--x11-misc/bbcd/bbcd-0.3.1-r5.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/bbcd/bbcd-0.3.1-r5.ebuild b/x11-misc/bbcd/bbcd-0.3.1-r5.ebuild
new file mode 100644
index 000000000000..250968d07f39
--- /dev/null
+++ b/x11-misc/bbcd/bbcd-0.3.1-r5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Basic CD Player for blackbox wm"
+HOMEPAGE="http://tranber1.free.fr/bbcd.html"
+SRC_URI="http://tranber1.free.fr/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=">=media-libs/libcdaudio-0.99.12-r4
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-libs/libXt"
+
+PATCHES=(
+ "${FILESDIR}"/${P}_${PV}a.diff
+ "${FILESDIR}"/${P}-gcc3.3.patch
+ "${FILESDIR}"/${P}-gcc4.3.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=c++14
+ econf \
+ --with-x \
+ --x-includes=/usr/include/X11 \
+ --x-libraries=/usr/lib64/x86_64-linux-gnu
+}
+
+src_install() {
+ default
+ rm "${ED}/usr/share/bbtools/README.bbcd" || die
+}