summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/bbmail/bbmail-0.9.3-r2.ebuild')
-rw-r--r--x11-misc/bbmail/bbmail-0.9.3-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/bbmail/bbmail-0.9.3-r2.ebuild b/x11-misc/bbmail/bbmail-0.9.3-r2.ebuild
new file mode 100644
index 000000000000..82cb99da07ba
--- /dev/null
+++ b/x11-misc/bbmail/bbmail-0.9.3-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="blackbox mail notification"
+HOMEPAGE="https://sourceforge.net/projects/bbtools"
+SRC_URI="mirror://sourceforge/bbtools/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/perl
+ x11-wm/blackbox
+ x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc4.3.patch
+ "${FILESDIR}"/${P}-gcc4.4.patch
+ "${FILESDIR}"/${P}-shebang.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ dobin scripts/bbmailparsefm.pl
+}