summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/bmpanel')
-rw-r--r--x11-misc/bmpanel/Manifest1
-rw-r--r--x11-misc/bmpanel/bmpanel-0.9.27-r1.ebuild47
-rw-r--r--x11-misc/bmpanel/files/Makefile.patch14
-rw-r--r--x11-misc/bmpanel/metadata.xml11
4 files changed, 73 insertions, 0 deletions
diff --git a/x11-misc/bmpanel/Manifest b/x11-misc/bmpanel/Manifest
new file mode 100644
index 000000000000..ced7a35a98d9
--- /dev/null
+++ b/x11-misc/bmpanel/Manifest
@@ -0,0 +1 @@
+DIST bmpanel-0.9.27.tar.gz 30638 SHA256 a6976d024800b878117161174cc6ca57b21b2462666e75111cdd32eea8464557 SHA512 fc36db740ead9700156b24d1fea8fda6ac99b77db54f1a8d832a1d22075dc0f1034ad948e7b1506cec79db06a185494c2b7937dd76e220153aad0c6862ccc70d WHIRLPOOL 3e956b49854eb622cce8b4ca782e8e5427422694d9817c47b8b5763e2a1261e28b3fe24d1957ab6ea647a3d4436e910dc609c58de6335b04b0d917c6e1819804
diff --git a/x11-misc/bmpanel/bmpanel-0.9.27-r1.ebuild b/x11-misc/bmpanel/bmpanel-0.9.27-r1.ebuild
new file mode 100644
index 000000000000..cce6a31cb75a
--- /dev/null
+++ b/x11-misc/bmpanel/bmpanel-0.9.27-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit base eutils
+
+DESCRIPTION="a lightweight, NETWM compliant panel for X11 Window System"
+HOMEPAGE="http://nsf.110mb.com/bmpanel"
+SRC_URI="http://nsf.110mb.com/${PN}/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~x86"
+IUSE="debug libev libevent"
+
+RDEPEND=">=media-libs/imlib2-1.4.0[X]
+ media-libs/freetype:2
+ x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXcomposite
+ x11-libs/libXfixes
+ media-libs/fontconfig
+ libev? ( dev-libs/libev )
+ libevent? ( dev-libs/libevent )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/Makefile.patch"
+)
+
+DOCS=( AUTHORS README )
+
+src_configure() {
+ # the provided configure script is broken.
+ # it doesn't provide --disable-foo, --host etc. so we can't use econf here.
+ local myconf="--prefix=/usr --ugly"
+
+ use debug && myconf="${myconf} --debug"
+ use libev && myconf="${myconf} --with-ev"
+ use libevent && myconf="${myconf} --with-event"
+
+ einfo "./configure ${myconf}"
+ ./configure ${myconf} || die "configure failed"
+}
diff --git a/x11-misc/bmpanel/files/Makefile.patch b/x11-misc/bmpanel/files/Makefile.patch
new file mode 100644
index 000000000000..d9cdc8308837
--- /dev/null
+++ b/x11-misc/bmpanel/files/Makefile.patch
@@ -0,0 +1,14 @@
+--- src/Makefile.old 2009-02-15 16:12:16.750885874 +0100
++++ src/Makefile 2009-02-15 16:16:24.560106442 +0100
+@@ -12,10 +12,7 @@ ifneq ($(UGLY),1)
+ endif
+
+ $(APP): $(OBJS)
+- $(V_L)$(LD) $(LIBS) -o $@ $(OBJS)
+-ifeq ($(DEBUG),0)
+- $(V_S)strip -s $(APP)
+-endif
++ $(V_L)$(LD) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
+
+ $(BUILDDIR)/src/%.o: src/%.c .mk/config.mk
+ $(V_C)$(CC) -c -MMD $(CFLAGS) $< -o $@
diff --git a/x11-misc/bmpanel/metadata.xml b/x11-misc/bmpanel/metadata.xml
new file mode 100644
index 000000000000..87d6ecef4754
--- /dev/null
+++ b/x11-misc/bmpanel/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name='libev'>Use the libev event loop interface</flag>
+ <flag name='libevent'>Use the libevent event loop interface</flag>
+ </use>
+</pkgmetadata>