summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/bumblebee/bumblebee-9999.ebuild')
-rw-r--r--x11-misc/bumblebee/bumblebee-9999.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/x11-misc/bumblebee/bumblebee-9999.ebuild b/x11-misc/bumblebee/bumblebee-9999.ebuild
index b9699790cb80..4c2cecf46ce5 100644
--- a/x11-misc/bumblebee/bumblebee-9999.ebuild
+++ b/x11-misc/bumblebee/bumblebee-9999.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools multilib readme.gentoo-r1 systemd user
+inherit autotools readme.gentoo-r1 systemd
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Bumblebee-Project/Bumblebee.git"
EGIT_BRANCH="develop"
else
- COMMIT="c322bd849aabe6e48b4304b8d13cc4aadc36a30d"
+ COMMIT="8f3d307b6aabbc2cd8444c6e5a4360f3bf2915ec"
SRC_URI="https://github.com/Bumblebee-Project/Bumblebee/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
@@ -32,13 +32,16 @@ COMMON_DEPEND="
x11-libs/libX11
"
-RDEPEND="${COMMON_DEPEND}
+RDEPEND="
+ ${COMMON_DEPEND}
+ acct-group/bumblebee
virtual/opengl
x11-base/xorg-drivers[video_cards_nvidia?,video_cards_nouveau?]
bbswitch? ( sys-power/bbswitch )
"
-DEPEND="${COMMON_DEPEND}
+DEPEND="
+ ${COMMON_DEPEND}
sys-apps/help2man
virtual/pkgconfig
"
@@ -52,10 +55,6 @@ PDEPEND="
REQUIRED_USE="|| ( video_cards_nouveau video_cards_nvidia )"
-pkg_setup() {
- enewgroup bumblebee
-}
-
src_prepare() {
default
eautoreconf