summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/cairo-clock')
-rw-r--r--x11-misc/cairo-clock/cairo-clock-0.3.4-r1.ebuild17
-rw-r--r--x11-misc/cairo-clock/cairo-clock-0.3.4-r2.ebuild44
2 files changed, 53 insertions, 8 deletions
diff --git a/x11-misc/cairo-clock/cairo-clock-0.3.4-r1.ebuild b/x11-misc/cairo-clock/cairo-clock-0.3.4-r1.ebuild
index 3cc8a83d4971..2f6adc645265 100644
--- a/x11-misc/cairo-clock/cairo-clock-0.3.4-r1.ebuild
+++ b/x11-misc/cairo-clock/cairo-clock-0.3.4-r1.ebuild
@@ -1,8 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-
inherit autotools
DESCRIPTION="An analog clock displaying the system-time"
@@ -12,19 +11,21 @@ SRC_URI="http://macslow.thepimp.net/projects/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~x86"
-IUSE=""
-RDEPEND=">=dev-libs/glib-2.8
+RDEPEND="
+ >=dev-libs/glib-2.8
>=gnome-base/libglade-2.6
>=gnome-base/librsvg-2.14
>=x11-libs/cairo-1.2
>=x11-libs/gtk+-2.10:2
- >=x11-libs/pango-1.10"
-DEPEND="${DEPEND}
+ >=x11-libs/pango-1.10
+"
+DEPEND="
+ ${RDEPEND}
dev-util/intltool
virtual/pkgconfig
- sys-devel/gettext"
-
+ sys-devel/gettext
+"
PATCHES=(
"${FILESDIR}"/${P}-desktop.patch
"${FILESDIR}"/${P}-linker.patch
diff --git a/x11-misc/cairo-clock/cairo-clock-0.3.4-r2.ebuild b/x11-misc/cairo-clock/cairo-clock-0.3.4-r2.ebuild
new file mode 100644
index 000000000000..675a9bf64b02
--- /dev/null
+++ b/x11-misc/cairo-clock/cairo-clock-0.3.4-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="An analog clock displaying the system-time"
+HOMEPAGE="https://launchpad.net/cairo-clock"
+SRC_URI="http://macslow.thepimp.net/projects/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.8
+ >=gnome-base/libglade-2.6
+ >=gnome-base/librsvg-2.14
+ >=x11-libs/cairo-1.2
+ >=x11-libs/gtk+-2.10:2
+ >=x11-libs/pango-1.10
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-desktop.patch
+ "${FILESDIR}"/${P}-linker.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ gzip -d "${ED}"/usr/share/man/man1/cairo-clock.1.gz || die
+}