summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/dmenu/dmenu-4.9.ebuild')
-rw-r--r--x11-misc/dmenu/dmenu-4.9.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/x11-misc/dmenu/dmenu-4.9.ebuild b/x11-misc/dmenu/dmenu-4.9.ebuild
deleted file mode 100644
index 29be48084efc..000000000000
--- a/x11-misc/dmenu/dmenu-4.9.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit savedconfig toolchain-funcs
-
-DESCRIPTION="a generic, highly customizable, and efficient menu for the X Window System"
-HOMEPAGE="https://tools.suckless.org/dmenu/"
-SRC_URI="https://dl.suckless.org/tools/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
-IUSE="xinerama"
-
-RDEPEND="
- media-libs/fontconfig
- x11-libs/libX11
- x11-libs/libXft
- xinerama? ( x11-libs/libXinerama )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- x11-base/xorg-proto
-"
-PATCHES=(
- "${FILESDIR}"/${PN}-4.9-gentoo.patch
-)
-
-src_prepare() {
- default
-
- sed -i \
- -e 's|^ @| |g' \
- -e '/^ echo/d' \
- Makefile || die
-
- restore_config config.h
-}
-
-src_compile() {
- emake CC=$(tc-getCC) \
- "FREETYPEINC=$( $(tc-getPKG_CONFIG) --cflags x11 fontconfig xft 2>/dev/null )" \
- "FREETYPELIBS=$( $(tc-getPKG_CONFIG) --libs x11 fontconfig xft 2>/dev/null )" \
- "X11INC=$( $(tc-getPKG_CONFIG) --cflags x11 2>/dev/null )" \
- "X11LIB=$( $(tc-getPKG_CONFIG) --libs x11 2>/dev/null )" \
- "XINERAMAFLAGS=$(
- usex xinerama "-DXINERAMA $(
- $(tc-getPKG_CONFIG) --cflags xinerama 2>/dev/null
- )" ''
- )" \
- "XINERAMALIBS=$(
- usex xinerama "$( $(tc-getPKG_CONFIG) --libs xinerama 2>/dev/null)" ''
- )"
-}
-
-src_install() {
- emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
-
- save_config config.h
-}