summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/dragbox')
-rw-r--r--x11-misc/dragbox/Manifest1
-rw-r--r--x11-misc/dragbox/dragbox-0.4.0.ebuild48
-rw-r--r--x11-misc/dragbox/metadata.xml9
3 files changed, 58 insertions, 0 deletions
diff --git a/x11-misc/dragbox/Manifest b/x11-misc/dragbox/Manifest
new file mode 100644
index 000000000000..28fb3f9a837a
--- /dev/null
+++ b/x11-misc/dragbox/Manifest
@@ -0,0 +1 @@
+DIST dragbox-0.4.0.tar.gz 88019 RMD160 741fdb9cd4e489df6a4d014f44b80469ca2e1181 SHA1 880deea590bb656e4c61360e83001b677546e5e5 SHA256 ba5dc05818cc991b4581e2b3987148043df786a60da1cf88e119d0dd4e4cd77f
diff --git a/x11-misc/dragbox/dragbox-0.4.0.ebuild b/x11-misc/dragbox/dragbox-0.4.0.ebuild
new file mode 100644
index 000000000000..b46f9a054ad1
--- /dev/null
+++ b/x11-misc/dragbox/dragbox-0.4.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+PYTHON_DEPEND="2"
+inherit python
+
+DESCRIPTION="GTK tool for connecting the commandline with the desktop environment"
+HOMEPAGE="http://kaizer.se/wiki/dragbox/"
+SRC_URI="http://kaizer.se/publicfiles/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/pygtk:2
+ gnome-base/libglade:2.0
+ dev-python/gnome-vfs-python:2
+ dev-python/libgnome-python:2
+ dev-python/gconf-python:2
+ sys-apps/dbus
+ x11-libs/gtk+:2"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_clean_py-compile_files
+ python_convert_shebangs 2 dragbox
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ python_mod_optimize Dragbox
+}
+
+pkg_postrm() {
+ python_mod_cleanup Dragbox
+}
diff --git a/x11-misc/dragbox/metadata.xml b/x11-misc/dragbox/metadata.xml
new file mode 100644
index 000000000000..92b31095ea4a
--- /dev/null
+++ b/x11-misc/dragbox/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>