summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/gcolor2/files')
-rw-r--r--x11-misc/gcolor2/files/gcolor2-0.4-amd64.patch46
-rw-r--r--x11-misc/gcolor2/files/gcolor2-0.4-fno-common.patch27
-rw-r--r--x11-misc/gcolor2/files/gcolor2-0.4-pkg-config-macro.patch10
-rw-r--r--x11-misc/gcolor2/files/modular-rgb.patch21
4 files changed, 0 insertions, 104 deletions
diff --git a/x11-misc/gcolor2/files/gcolor2-0.4-amd64.patch b/x11-misc/gcolor2/files/gcolor2-0.4-amd64.patch
deleted file mode 100644
index cd06a8315f98..000000000000
--- a/x11-misc/gcolor2/files/gcolor2-0.4-amd64.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff --exclude-from=/home/dang/bin/scripts/diffrc -up -ruN gcolor2-0.4.orig/src/callbacks.c gcolor2-0.4/src/callbacks.c
---- gcolor2-0.4.orig/src/callbacks.c 2005-07-12 14:06:12.000000000 -0400
-+++ gcolor2-0.4/src/callbacks.c 2007-02-17 19:19:38.000000000 -0500
-@@ -4,6 +4,9 @@
-
- #include <gtk/gtk.h>
- #include <stdio.h>
-+#include <string.h>
-+#include <glib.h>
-+#include <glib/gprintf.h>
-
- #include "callbacks.h"
- #include "interface.h"
-@@ -172,6 +175,9 @@ void on_copy_color_to_clipboard_activate
- gtk_clipboard_set_text (cb, hex, strlen (hex));
- }
-
-+void add_rgb_file (gchar *filename, gchar *type);
-+gchar* get_system_file (void);
-+
- void on_show_system_colors_activate (GtkMenuItem *menuitem, gpointer user_data)
- {
- if (gtk_check_menu_item_get_active (GTK_CHECK_MENU_ITEM (menuitem)))
-@@ -266,6 +272,8 @@ void on_save_button_clicked (GtkButton *
- gtk_widget_destroy (savedialog);
- }
-
-+void add_list_color (gchar *spec, gchar *name, gchar *type, gboolean is_new_color);
-+
- void add_color_to_treeview ()
- {
- GtkTreeView *treeview;
-diff --exclude-from=/home/dang/bin/scripts/diffrc -up -ruN gcolor2-0.4.orig/src/main.c gcolor2-0.4/src/main.c
---- gcolor2-0.4.orig/src/main.c 2005-07-11 10:55:49.000000000 -0400
-+++ gcolor2-0.4/src/main.c 2007-02-17 19:18:23.000000000 -0500
-@@ -4,6 +4,10 @@
-
- #include <gtk/gtk.h>
- #include <stdio.h>
-+#include <stdlib.h>
-+#include <string.h>
-+#include <glib.h>
-+#include <glib/gprintf.h>
-
- #include "interface.h"
- #include "support.h"
diff --git a/x11-misc/gcolor2/files/gcolor2-0.4-fno-common.patch b/x11-misc/gcolor2/files/gcolor2-0.4-fno-common.patch
deleted file mode 100644
index f30552a13e60..000000000000
--- a/x11-misc/gcolor2/files/gcolor2-0.4-fno-common.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/src/callbacks.c
-+++ b/src/callbacks.c
-@@ -13,6 +13,9 @@
- #include "support.h"
-
-
-+GtkWidget *gcolor2;
-+GtkWidget *menu;
-+GdkColor colorvalue;
- GtkWidget *savedialog;
- gchar *colorname;
- static GtkWidget *aboutdialog = NULL;
---- a/src/callbacks.h
-+++ b/src/callbacks.h
-@@ -42,9 +42,9 @@
- "\302\267 Usability / user interface enhancements\n" \
- "\302\267 Code cleanup"
-
--GtkWidget *gcolor2;
--GtkWidget *menu;
--GdkColor colorvalue;
-+extern GtkWidget *gcolor2;
-+extern GtkWidget *menu;
-+extern GdkColor colorvalue;
-
- enum
- {
diff --git a/x11-misc/gcolor2/files/gcolor2-0.4-pkg-config-macro.patch b/x11-misc/gcolor2/files/gcolor2-0.4-pkg-config-macro.patch
deleted file mode 100644
index c3fcca0af712..000000000000
--- a/x11-misc/gcolor2/files/gcolor2-0.4-pkg-config-macro.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -26,6 +26,7 @@
- AC_DISABLE_STATIC
- AC_PROG_LIBTOOL
- AC_PROG_INTLTOOL([0.27])
-+PKG_PROG_PKG_CONFIG
-
-
- GETTEXT_PACKAGE=gcolor2
diff --git a/x11-misc/gcolor2/files/modular-rgb.patch b/x11-misc/gcolor2/files/modular-rgb.patch
deleted file mode 100644
index 798fe57e2e3f..000000000000
--- a/x11-misc/gcolor2/files/modular-rgb.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/src/callbacks.h
-+++ b/src/callbacks.h
-@@ -12,6 +12,7 @@
- #define SYSTEM_FILE_2 "/usr/lib/X11/rgb.txt"
- #define SYSTEM_FILE_3 "/etc/X11/rgb.txt"
- #define SYSTEM_FILE_4 "/usr/openwin/lib/X11/rgb.txt"
-+#define SYSTEM_FILE_5 "/usr/share/X11/rgb.txt"
-
- /* about dialog text */
- #define ABOUT_CREDITS_TEXT "Developer:\n" \
---- a/src/main.c
-+++ b/src/main.c
-@@ -36,6 +36,8 @@
- sys_filename = SYSTEM_FILE_3;
- else if (g_file_test (SYSTEM_FILE_4, G_FILE_TEST_EXISTS))
- sys_filename = SYSTEM_FILE_4;
-+ else if (g_file_test (SYSTEM_FILE_5, G_FILE_TEST_EXISTS))
-+ sys_filename = SYSTEM_FILE_5;
- else
- return FALSE;
- return TRUE;