summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/hsetroot/hsetroot-1.0.5.ebuild')
-rw-r--r--x11-misc/hsetroot/hsetroot-1.0.5.ebuild23
1 files changed, 8 insertions, 15 deletions
diff --git a/x11-misc/hsetroot/hsetroot-1.0.5.ebuild b/x11-misc/hsetroot/hsetroot-1.0.5.ebuild
index cde4912ca941..a1e16b31f171 100644
--- a/x11-misc/hsetroot/hsetroot-1.0.5.ebuild
+++ b/x11-misc/hsetroot/hsetroot-1.0.5.ebuild
@@ -2,31 +2,24 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit toolchain-funcs
DESCRIPTION="Tool which allows you to compose wallpapers ('root pixmaps') for X"
HOMEPAGE="https://github.com/himdel/hsetroot/"
-SRC_URI="
- https://github.com/himdel/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
-"
+SRC_URI="https://github.com/himdel/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
-RDEPEND="
- >=media-libs/imlib2-1.0.6.2003[X]
+RDEPEND=">=media-libs/imlib2-1.0.6.2003[X]
x11-libs/libX11
- x11-libs/libXinerama
-"
-DEPEND="
- ${RDEPEND}
- x11-base/xorg-proto
-"
-BDEPEND="
- virtual/pkgconfig
-"
-DOCS="AUTHORS ChangeLog NEWS README"
+ x11-libs/libXinerama"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
PATCHES=(
"${FILESDIR}"/${PN}-1.0.5-XOpenDisplay.patch
)