summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/kapow')
-rw-r--r--x11-misc/kapow/Manifest1
-rw-r--r--x11-misc/kapow/kapow-1.5.5.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/x11-misc/kapow/Manifest b/x11-misc/kapow/Manifest
index 8352b90661f1..bc0c6132a49f 100644
--- a/x11-misc/kapow/Manifest
+++ b/x11-misc/kapow/Manifest
@@ -1,2 +1,3 @@
DIST kapow-1.5.3-src.tar.bz2 720315 BLAKE2B 1499a923624aadda894e818d29e5d1b4120ec5a9030988728a9662773ea3a02c32bf3edec4781407cdde2d89de027da35d4761172a8a8f7830f592d75a9acbf2 SHA512 1f8dcd570f6ed3b9fc1605a25628a06720839a5558b1564341bb775ebc99796b1124e498dced279aef30ba6fe3bb9d4f3b956685d07b481e79d66c7f197ae201
DIST kapow-1.5.4-src.tar.bz2 722095 BLAKE2B be90609a3dd6a6b521c39ef0fb4a6a20ec193f816a994f944f5083888d4e883829b2249c3ff0e0df6f232f87e33f5abfbbd0b4b624a1165a75c3fe8ceb9cb21f SHA512 03683e7a4f904c4b6efdf47401d8a15ba979484d52d58e4dea52a890351ba9342ef5fe383876c5cb8138c6d578122936ca7e9ffda0fc5eb090e719eb751764eb
+DIST kapow-1.5.5-src.tar.bz2 722262 BLAKE2B 5f1c66b38edded3f2ad1d76d97dab036264169176647a25dc618a6e4149b40f4d4ed368edbac7786440ef49fe77e896db084edd9c210cd278b92ba175d49c63d SHA512 d22f8c1de74333b31b49ec752118ce36624895f99073b4b3f57a78f32e331ed33365b5664a316604e573820d38f268f0ceb6531bbf60eca05aa4a09fe5436a20
diff --git a/x11-misc/kapow/kapow-1.5.5.ebuild b/x11-misc/kapow/kapow-1.5.5.ebuild
new file mode 100644
index 000000000000..50b3b86f7dde
--- /dev/null
+++ b/x11-misc/kapow/kapow-1.5.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qmake-utils
+
+DESCRIPTION="A punch clock program designed to easily keep track of your hours"
+HOMEPAGE="https://gottcode.org/kapow/"
+SRC_URI="https://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="
+ ${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+K_LINGUAS="
+ ar bg cs da de el en es fr it lt nl no pl pt_BR ro ru sv tr uk
+"
+for K_LINGUA in ${K_LINGUAS}; do
+ IUSE+=" linguas_${K_LINGUA}"
+done
+DOCS=( ChangeLog README )
+
+src_prepare() {
+ default
+
+ count() { echo ${#}; }
+ local lingua_count=$(count ${K_LINGUAS})
+ local locale_count=$(count translations/${PN}_*.ts)
+ [[ ${lingua_count} = ${locale_count} ]] \
+ || die "Number of LINGUAS does not match number of locales"
+ unset count
+
+ local lingua
+ if [[ -n "${LINGUAS}" ]]; then
+ for lingua in ${K_LINGUAS}; do
+ if ! use linguas_${lingua}; then
+ rm translations/${PN}_${lingua}.* || die
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ eqmake5 kapow.pro PREFIX=/usr
+}
+
+src_install() {
+ export INSTALL_ROOT="${D}"
+ default
+}