summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/oroborus-keylaunch')
-rw-r--r--x11-misc/oroborus-keylaunch/files/oroborus-keylaunch-1.3.9-makefile.patch44
-rw-r--r--x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9-r2.ebuild (renamed from x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9-r1.ebuild)25
2 files changed, 54 insertions, 15 deletions
diff --git a/x11-misc/oroborus-keylaunch/files/oroborus-keylaunch-1.3.9-makefile.patch b/x11-misc/oroborus-keylaunch/files/oroborus-keylaunch-1.3.9-makefile.patch
new file mode 100644
index 000000000000..523fd85aa0eb
--- /dev/null
+++ b/x11-misc/oroborus-keylaunch/files/oroborus-keylaunch-1.3.9-makefile.patch
@@ -0,0 +1,44 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -14,7 +14,7 @@
+ DOC_DIR = $(INSTDIR)/share/doc/$(PROG)
+
+
+-VERBOSE =
++VERBOSE = 1
+ ifeq ($(VERBOSE), 1)
+ Q =
+ else
+@@ -22,7 +22,8 @@
+ endif
+
+ CC = @CC@
+-CFLAGS = @CFLAGS@ @X_CFLAGS@ -g -O2 -Wall
++CFLAGS = @CFLAGS@ @X_CFLAGS@
++CPPFLAGS = @CPPFLAGS@
+ LIBS = @LIBS@ @X_LIBS@
+ LDFLAGS = @LDFLAGS@
+ RCFILE = .$(PROG)rc
+@@ -55,11 +56,11 @@
+
+ $(PROG): $(OBJS)
+ @echo "[ linking $< ]"
+- $Q$(CC) $< $(LDFLAGS) $(LIBS) -o $@
++ $Q$(CC) $(LDFLAGS) $(CFLAGS) $< -o $@ $(LIBS)
+
+ $(OBJS): %.o: %.c $(HEADERS)
+ @echo "[ compiling $< ]"
+- $Q$(CC) $(CFLAGS) $(DEFINES) -c $< -o $@
++ $Q$(CC) $(CFLAGS) $(CPPFLAGS) $(DEFINES) -c $< -o $@
+
+ install-mans:
+ @echo "[ installing manpages. (section 1) ]"
+@@ -71,7 +72,7 @@
+ $Q$(INSTALL) $(INST_CREATEDIR) $(DOC_DIR)
+ $Q$(INSTALL) $(INST_DOC_OPTS) $(DOCS) $(DOC_DIR)
+
+-install: all install-mans install-docs
++install: all install-mans
+ @echo "[ installing $(PROG) ]"
+ $Q$(INSTALL) $(INST_PROG_OPTS) $(PROG) $(BIN_DIR)/$(PROG)
+
diff --git a/x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9-r1.ebuild b/x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9-r2.ebuild
index aade3f2ad749..e3907005102c 100644
--- a/x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9-r1.ebuild
+++ b/x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9-r2.ebuild
@@ -1,34 +1,29 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
+WANT_AUTOMAKE=none
+inherit autotools
MY_PN=${PN/oroborus-//}
DESCRIPTION="utility for binding keys in Oroborus"
HOMEPAGE="https://www.oroborus.org"
SRC_URI="mirror://debian/pool/main/k/${MY_PN}/${MY_PN}_${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="x11-libs/libX11
- !x11-wm/oroborus-extras"
-RDEPEND="${DEPEND}"
-S=${WORKDIR}/${MY_PN}-${PV}
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
DOCS=( README docs/example_rc debian/changelog )
src_prepare() {
default
- sed -e "s: -g -O2 -Wall::" \
- -e "/^install:/s/install-docs//" \
- -i Makefile.in || die
-}
-
-src_compile() {
- emake VERBOSE=1
+ eautoconf # bug 898254
}