summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/slop/slop-7.6.ebuild')
-rw-r--r--x11-misc/slop/slop-7.6.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/x11-misc/slop/slop-7.6.ebuild b/x11-misc/slop/slop-7.6.ebuild
index eae133af55d8..7a396e8e3619 100644
--- a/x11-misc/slop/slop-7.6.ebuild
+++ b/x11-misc/slop/slop-7.6.ebuild
@@ -12,10 +12,10 @@ KEYWORDS="amd64 ~x86"
LICENSE="GPL-3"
SLOT="0/${PV}"
-IUSE="opengl"
+IUSE="opengl icu"
RDEPEND="
- dev-libs/icu:=
+ icu? ( dev-libs/icu:= )
x11-libs/libX11
x11-libs/libXext
opengl? (
@@ -37,6 +37,9 @@ DEPEND="
PATCHES=( "${FILESDIR}/${PN}"-7.5-missing-header.patch )
src_configure() {
- local mycmakeargs=( -DSLOP_OPENGL=$(usex opengl) )
+ local mycmakeargs=(
+ -DSLOP_OPENGL=$(usex opengl)
+ -DSLOP_UNICODE=$(usex icu)
+ )
cmake_src_configure
}