summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/stalonetray')
-rw-r--r--x11-misc/stalonetray/Manifest1
-rw-r--r--x11-misc/stalonetray/metadata.xml2
-rw-r--r--x11-misc/stalonetray/stalonetray-0.8.4.ebuild42
3 files changed, 44 insertions, 1 deletions
diff --git a/x11-misc/stalonetray/Manifest b/x11-misc/stalonetray/Manifest
index 98ae718aa32d..35ae306a81f0 100644
--- a/x11-misc/stalonetray/Manifest
+++ b/x11-misc/stalonetray/Manifest
@@ -1 +1,2 @@
DIST stalonetray-0.8.3.tar.bz2 155276 BLAKE2B 68041239df7d3441f9abd279cec55ff11deb0ef73eb984be8ad2f0348285164c112918c9e850e5fd2a994144a0c84429164e9f46a0baf81a29ed763b750ffce7 SHA512 b1c50d844b6497b586c1ad56b721675690ea305a4e3a2601ab5305af0e208c215825eefa8fa374ae0c392252156a8dffd5882992c943344f5b6a674fe6553942
+DIST stalonetray-0.8.4.tar.gz 94614 BLAKE2B 4def696bbd580960f2d7fd84516658e4b4112b40989523840566d34dac71ba92e3adf021796059db919515cc978ac0c5d7783a4ed41aa9f82c8cbcfd00bc958b SHA512 3afdeb7794171f490c5eca631c574003a00bbed863b9caf4024e1b064772d3c24ea3836f280eeab1d50def67928f4d08d3d375047f43bcc39f16a3250015ff2b
diff --git a/x11-misc/stalonetray/metadata.xml b/x11-misc/stalonetray/metadata.xml
index 06c9ae6364e0..c3b369f27a31 100644
--- a/x11-misc/stalonetray/metadata.xml
+++ b/x11-misc/stalonetray/metadata.xml
@@ -10,7 +10,7 @@
<name>Proxy Maintainers</name>
</maintainer>
<use>
- <flag name="graceful-exit">use non-portable hack to exit gracefuly on signal</flag>
+ <flag name="graceful-exit">use non-portable hack to exit gracefully on signal</flag>
</use>
<upstream>
<remote-id type="sourceforge">stalonetray</remote-id>
diff --git a/x11-misc/stalonetray/stalonetray-0.8.4.ebuild b/x11-misc/stalonetray/stalonetray-0.8.4.ebuild
new file mode 100644
index 000000000000..457429b37475
--- /dev/null
+++ b/x11-misc/stalonetray/stalonetray-0.8.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="System tray utility including support for KDE system tray icons"
+HOMEPAGE="https://stalonetray.github.io/"
+SRC_URI="https://github.com/kolbusa/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +graceful-exit"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="app-text/docbook-xml-dtd
+ dev-libs/libxslt"
+
+DOCS=( AUTHORS BUGS COPYING NEWS README.md TODO stalonetrayrc.sample stalonetray.html )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug) \
+ $(use_enable graceful-exit) \
+ --enable-native-kde
+}
+
+src_compile() {
+ emake
+ emake dist
+}