summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/sunflower/sunflower-0.4_p20200716-r1.ebuild')
-rw-r--r--x11-misc/sunflower/sunflower-0.4_p20200716-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/sunflower/sunflower-0.4_p20200716-r1.ebuild b/x11-misc/sunflower/sunflower-0.4_p20200716-r1.ebuild
new file mode 100644
index 000000000000..7c86bc5a3e18
--- /dev/null
+++ b/x11-misc/sunflower/sunflower-0.4_p20200716-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Small and highly customizable twin-panel file manager with plugin-support"
+HOMEPAGE="https://github.com/MeanEYE/Sunflower
+ https://sunflower-fm.org/"
+SRC_URI="https://dev.gentoo.org/~slashbeast/distfiles/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+"
+
+RDEPEND="${DEPEND}
+ dev-python/pycairo[${PYTHON_USEDEP}]
+"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}