summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/vdpauinfo/vdpauinfo-1.5-r1.ebuild')
-rw-r--r--x11-misc/vdpauinfo/vdpauinfo-1.5-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-misc/vdpauinfo/vdpauinfo-1.5-r1.ebuild b/x11-misc/vdpauinfo/vdpauinfo-1.5-r1.ebuild
new file mode 100644
index 000000000000..0a5e0bfd4ccd
--- /dev/null
+++ b/x11-misc/vdpauinfo/vdpauinfo-1.5-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Displays info about your card's VDPAU support"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/VDPAU/"
+SRC_URI="https://gitlab.freedesktop.org/vdpau/vdpauinfo/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ >=x11-libs/libvdpau-1.5
+ x11-libs/libX11"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ append-flags -fno-strict-aliasing #864755
+}