summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/x2x/x2x-1.30-r1.ebuild')
-rw-r--r--x11-misc/x2x/x2x-1.30-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-misc/x2x/x2x-1.30-r1.ebuild b/x11-misc/x2x/x2x-1.30-r1.ebuild
new file mode 100644
index 000000000000..505f19649f03
--- /dev/null
+++ b/x11-misc/x2x/x2x-1.30-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A utility to connect the mouse and keyboard to another X"
+HOMEPAGE="https://github.com/dottedmag/x2x"
+SRC_URI="https://github.com/dottedmag/x2x/archive/refs/tags/debian/${PV}-10.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-debian-1.30-10
+
+LICENSE="MIT BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~mips ppc x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXtst
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ # Patch to fix bug #126939
+ # AltGr does not work in x2x with different keymaps:
+ "${FILESDIR}"/${PN}_1.30-10-keymap.patch
+)
+
+DOCS=( README AUTHORS INSTALL ChangeLog ChangeLog.old )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CDEBUGFLAGS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ default
+ dodoc -r docs/
+}