summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xbatt/xbatt-1.3_rc1.ebuild')
-rw-r--r--x11-misc/xbatt/xbatt-1.3_rc1.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/x11-misc/xbatt/xbatt-1.3_rc1.ebuild b/x11-misc/xbatt/xbatt-1.3_rc1.ebuild
index 75a3899848d4..df26d01cbd2c 100644
--- a/x11-misc/xbatt/xbatt-1.3_rc1.ebuild
+++ b/x11-misc/xbatt/xbatt-1.3_rc1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -24,15 +24,19 @@ RDEPEND="
DEPEND="
${RDEPEND}
x11-base/xorg-proto
- x11-misc/imake
+ >=x11-misc/imake-1.0.8-r1
"
PATCHES=(
"${FILESDIR}"/${PN}-1.2.1-implicits.patch
)
S="${WORKDIR}"/${PN}-$(ver_cut 1-2)
+src_configure() {
+ CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
+ IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
+}
+
src_compile() {
- xmkmf || die
emake \
CC="$(tc-getCC)" \
CDEBUGFLAGS="${CFLAGS}" \