summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xdg-user-dirs-gtk')
-rw-r--r--x11-misc/xdg-user-dirs-gtk/Manifest2
-rw-r--r--x11-misc/xdg-user-dirs-gtk/metadata.xml8
-rw-r--r--x11-misc/xdg-user-dirs-gtk/xdg-user-dirs-gtk-0.10.ebuild37
-rw-r--r--x11-misc/xdg-user-dirs-gtk/xdg-user-dirs-gtk-0.9.ebuild37
4 files changed, 84 insertions, 0 deletions
diff --git a/x11-misc/xdg-user-dirs-gtk/Manifest b/x11-misc/xdg-user-dirs-gtk/Manifest
new file mode 100644
index 000000000000..bbecf86564cc
--- /dev/null
+++ b/x11-misc/xdg-user-dirs-gtk/Manifest
@@ -0,0 +1,2 @@
+DIST xdg-user-dirs-gtk-0.10.tar.xz 116528 SHA256 739a1a89baf34aa7261e924a21d2ae646b0475b67b3db3daa84327a99132d83e SHA512 c3ef070244cd1c87312c2c2602dbe7bc3dd26eed632b0d8d779580d7ee6259efdda453ab7bdf4415cc72fad7a74d9dd36476189fe446d5627e4db75d905302f5 WHIRLPOOL 5fc149fd8f08569cf5d1223f6c1b7d7162a3b40554dd7af765b757fb2fad555dc6630ccbdbaf740a715c21519a5a168c303a3fd18ef1971728fad828628465f7
+DIST xdg-user-dirs-gtk-0.9.tar.xz 112828 SHA256 4b908252515eb95b27427ef7c6b0e096febde716c0c89e8f03a79d23882b79c8 SHA512 ea963c06ff00a291e0e7f0ae11469c073c3cfc96320b5dd463de521cf7f92c3aa05670a62d3d9a6c4db35f22009fd0ea949195181e0e04fb7c190c6205213270 WHIRLPOOL d3375a263bd837d4ea2f833d3d4dc3dfb993f670e6727eb4c4d34e2bd5a804fee5f33e740444112744638c65482669cc69e639185ae427047adbbd4e46e8936b
diff --git a/x11-misc/xdg-user-dirs-gtk/metadata.xml b/x11-misc/xdg-user-dirs-gtk/metadata.xml
new file mode 100644
index 000000000000..9879e83b822e
--- /dev/null
+++ b/x11-misc/xdg-user-dirs-gtk/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>freedesktop</herd>
+ <maintainer>
+ <email>freedesktop-bugs@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-misc/xdg-user-dirs-gtk/xdg-user-dirs-gtk-0.10.ebuild b/x11-misc/xdg-user-dirs-gtk/xdg-user-dirs-gtk-0.10.ebuild
new file mode 100644
index 000000000000..04663ffa38c3
--- /dev/null
+++ b/x11-misc/xdg-user-dirs-gtk/xdg-user-dirs-gtk-0.10.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit gnome.org readme.gentoo
+
+DESCRIPTION="xdg-user-dirs-gtk integrates xdg-user-dirs into the Gnome desktop and Gtk+ applications"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/xdg-user-dirs"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ >=x11-misc/xdg-user-dirs-0.14
+ >=x11-libs/gtk+-3.5.1:3
+"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="
+ This package tries to automatically use some sensible default
+ directories for your documents, music, video and other stuff.
+ If you want to change those directories to your needs, see
+ the settings in ~/.config/user-dir.dirs
+"
+
+src_prepare() {
+ sed -i \
+ -e '/Encoding/d' \
+ -e 's:OnlyShowIn=GNOME;LXDE;Unity;:NotShowIn=KDE;:' \
+ user-dirs-update-gtk.desktop.in || die
+}
diff --git a/x11-misc/xdg-user-dirs-gtk/xdg-user-dirs-gtk-0.9.ebuild b/x11-misc/xdg-user-dirs-gtk/xdg-user-dirs-gtk-0.9.ebuild
new file mode 100644
index 000000000000..820a8f276fea
--- /dev/null
+++ b/x11-misc/xdg-user-dirs-gtk/xdg-user-dirs-gtk-0.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit gnome.org
+
+DESCRIPTION="xdg-user-dirs-gtk integrates xdg-user-dirs into the Gnome desktop and Gtk+ applications"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/xdg-user-dirs"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=x11-misc/xdg-user-dirs-0.14
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e '/Encoding/d' \
+ -e 's:OnlyShowIn=GNOME;LXDE;Unity;:NotShowIn=KDE;:' \
+ user-dirs-update-gtk.desktop.in || die
+}
+
+pkg_postinst() {
+ elog
+ elog " This package tries to automatically use some sensible default "
+ elog " directories for your documents, music, video and other stuff. "
+ elog
+ elog " If you want to change those directories to your needs, see "
+ elog " the settings in ~/.config/user-dir.dirs "
+ elog
+}