summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xdotool/xdotool-2.20110530.1.ebuild')
-rw-r--r--x11-misc/xdotool/xdotool-2.20110530.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-misc/xdotool/xdotool-2.20110530.1.ebuild b/x11-misc/xdotool/xdotool-2.20110530.1.ebuild
new file mode 100644
index 000000000000..4e49c063adcb
--- /dev/null
+++ b/x11-misc/xdotool/xdotool-2.20110530.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils toolchain-funcs flag-o-matic multilib
+
+DESCRIPTION="Simulate keyboard input and mouse activity, move and resize windows"
+HOMEPAGE="http://www.semicomplete.com/projects/xdotool/"
+SRC_URI="http://semicomplete.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm ppc x86"
+IUSE="examples"
+
+RDEPEND="x11-libs/libXtst
+ x11-libs/libX11
+ x11-libs/libXinerama"
+DEPEND="${RDEPEND}"
+
+# The test wants to manualy start Xvfb, wont use VirtualX and it tries
+# to run a full gnome-session. For such a tiny application i consider
+# it overkill to rewrite the test scripts to not use it's own X server
+# and add a full blown gnome just to run the tests.
+RESTRICT="test"
+
+src_prepare() {
+ sed -i \
+ -e "s/installheader post-install$/installheader/" \
+ -e 's:\<pkg-config\>:$(PKG_CONFIG):' \
+ Makefile || die "sed failed"
+}
+
+src_compile() {
+ tc-export CC LD PKG_CONFIG
+ default
+}
+
+src_install() {
+ emake PREFIX="${D}usr" INSTALLMAN="${D}usr/share/man" INSTALLLIB="${D}usr/$(get_libdir)" install || die
+
+ dodoc CHANGELIST README
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}