summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xfishtank')
-rw-r--r--x11-misc/xfishtank/Manifest1
-rw-r--r--x11-misc/xfishtank/files/xfishtank-2.1-implicits.patch75
-rw-r--r--x11-misc/xfishtank/files/xfishtank-2.1tp-Makefile.patch12
-rw-r--r--x11-misc/xfishtank/metadata.xml5
-rw-r--r--x11-misc/xfishtank/xfishtank-2.1-r1.ebuild42
-rw-r--r--x11-misc/xfishtank/xfishtank-2.1.ebuild42
6 files changed, 177 insertions, 0 deletions
diff --git a/x11-misc/xfishtank/Manifest b/x11-misc/xfishtank/Manifest
new file mode 100644
index 000000000000..fc536b17fc9c
--- /dev/null
+++ b/x11-misc/xfishtank/Manifest
@@ -0,0 +1 @@
+DIST xfishtank-2.1tp.tar.gz 187513 SHA256 afaedcecd61716fce6c008598dc5750f8d061ae23a36afbab426d0d2cc922240
diff --git a/x11-misc/xfishtank/files/xfishtank-2.1-implicits.patch b/x11-misc/xfishtank/files/xfishtank-2.1-implicits.patch
new file mode 100644
index 000000000000..0a4a03503246
--- /dev/null
+++ b/x11-misc/xfishtank/files/xfishtank-2.1-implicits.patch
@@ -0,0 +1,75 @@
+--- xfishtank-2.1tp/read.c
++++ xfishtank-2.1tp/read.c
+@@ -1,5 +1,7 @@
+ #include <X11/Xlib.h>
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include "compact.h"
+ #include "medcut.h"
+
+--- xfishtank-2.1tp/medcut.c
++++ xfishtank-2.1tp/medcut.c
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "medcut.h"
+
+ #define RED 0
+--- xfishtank-2.1tp/xfish.c
++++ xfishtank-2.1tp/xfish.c
+@@ -46,6 +46,9 @@
+ #endif
+
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
++#include <unistd.h>
+ #ifdef sgi
+ #define _BSD_SIGNALS
+ #endif
+@@ -848,8 +850,8 @@
+ struct colr_data colrs[256];
+
+ colormap = XDefaultColormap(Dpy, screen);
+
+- if (colormap == NULL)
++ if (colormap == 0)
+ {
+ return;
+ }
+@@ -1812,9 +1814,11 @@
+ high_res_sleep(seconds)
+ double seconds;
+ {
+- int fds = 0;
++ fd_set fds;
+ struct timeval timeout;
+
++ FD_ZERO(&fds);
++
+ timeout.tv_sec = seconds;
+ timeout.tv_usec = (seconds - timeout.tv_sec) * 1000000.0;
+ select(0, &fds, &fds, &fds, &timeout);
+--- xfishtank-2.1tp/makeh.c
++++ xfishtank-2.1tp/makeh.c
+@@ -1,6 +1,6 @@
+-
++#include <stdlib.h>
+ #include <stdio.h>
+-
++#include <string.h>
+ main()
+ {
+ FILE *fp;
+--- xfishtank-2.1tp/gifread.c
++++ xfishtank-2.1tp/gifread.c
+@@ -56,6 +56,8 @@
+
+ #include <X11/Xlib.h>
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #if defined(SYSV) || defined(SVR4)
+ #include <string.h>
+ #else /* SYSV */
diff --git a/x11-misc/xfishtank/files/xfishtank-2.1tp-Makefile.patch b/x11-misc/xfishtank/files/xfishtank-2.1tp-Makefile.patch
new file mode 100644
index 000000000000..df404b1949b0
--- /dev/null
+++ b/x11-misc/xfishtank/files/xfishtank-2.1tp-Makefile.patch
@@ -0,0 +1,12 @@
+diff -Nru xfishtank-2.1tp.vanilla/Makefile xfishtank-2.1tp/Makefile
+--- xfishtank-2.1tp.vanilla/Makefile 2005-12-18 16:21:08.000000000 +0100
++++ xfishtank-2.1tp/Makefile 2005-12-18 16:23:06.000000000 +0100
+@@ -212,7 +212,7 @@
+
+ ALLINCLUDES = $(INCLUDES) $(EXTRA_INCLUDES) $(TOP_INCLUDES) $(STD_INCLUDES)
+ ALLDEFINES = $(ALLINCLUDES) $(STD_DEFINES) $(EXTRA_DEFINES) $(PROTO_DEFINES) $(THREADS_DEFINES) $(DEFINES)
+- CFLAGS = $(CDEBUGFLAGS) $(CCOPTIONS) $(THREADS_CFLAGS) $(ALLDEFINES)
++ CFLAGS += $(CCOPTIONS) $(THREADS_CFLAGS) $(ALLDEFINES)
+ LINTFLAGS = $(LINTOPTS) -DLINT $(ALLDEFINES) $(DEPEND_DEFINES)
+ LDPRELIB = -L$(USRLIBDIR)
+ LDPOSTLIB =
diff --git a/x11-misc/xfishtank/metadata.xml b/x11-misc/xfishtank/metadata.xml
new file mode 100644
index 000000000000..731225048652
--- /dev/null
+++ b/x11-misc/xfishtank/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>
diff --git a/x11-misc/xfishtank/xfishtank-2.1-r1.ebuild b/x11-misc/xfishtank/xfishtank-2.1-r1.ebuild
new file mode 100644
index 000000000000..12b55ec45b94
--- /dev/null
+++ b/x11-misc/xfishtank/xfishtank-2.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+MY_P=${P}tp
+
+DESCRIPTION="Turns your root window into an aquarium"
+HOMEPAGE="http://www.ibiblio.org/pub/Linux/X11/demos/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/X11/demos/${MY_P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-linux"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-misc/imake"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-implicits.patch
+}
+
+src_compile() {
+ xmkmf || die
+ emake CDEBUGFLAGS="${CFLAGS}" CC="$(tc-getCC)" \
+ EXTRA_LDOPTIONS="${LDFLAGS}" ${PN} || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README README.Linux README.TrueColor README.Why.2.1tp || die
+}
diff --git a/x11-misc/xfishtank/xfishtank-2.1.ebuild b/x11-misc/xfishtank/xfishtank-2.1.ebuild
new file mode 100644
index 000000000000..03021e8d23de
--- /dev/null
+++ b/x11-misc/xfishtank/xfishtank-2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+MY_P=${P}tp
+
+DESCRIPTION="Turns your root window into an aquarium"
+HOMEPAGE="http://www.ibiblio.org/pub/Linux/X11/demos/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/X11/demos/${MY_P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="ppc ppc64 x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-misc/makedepend"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/${MY_P}-Makefile.patch"
+ cd "${S}"
+ sed -i -e 's,INSTPGMFLAGS = -s,INSTPGMFLAGS =,' Makefile || die
+}
+
+src_compile() {
+ makedepend || die "makedepend failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make BINDIR=/usr/bin DESTDIR="${D}" install || die "make install failed"
+ dodoc README README.Linux README.TrueColor README.Why.2.1tp
+}