summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xwallpaper')
-rw-r--r--x11-misc/xwallpaper/Manifest1
-rw-r--r--x11-misc/xwallpaper/xwallpaper-0.7.4.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/x11-misc/xwallpaper/Manifest b/x11-misc/xwallpaper/Manifest
index 24b4414b228e..00c689ce1094 100644
--- a/x11-misc/xwallpaper/Manifest
+++ b/x11-misc/xwallpaper/Manifest
@@ -1 +1,2 @@
DIST xwallpaper-0.7.3.tar.xz 86388 BLAKE2B 45942dbe7e3627fbbf99ac5ab94c88ecea919e48131f268f0be10a0fba15a4feddf207c0787ac47f75bc6a5cc94f2b78d599e97950609196930a73073ae21ec1 SHA512 7fa9cc9ca2445afdfcb647724a6dc8bb3b52b9a6c91d237f6b443cf1fe6624c67d16d611bf4e435c5f3dcdae6cbf73bbde257a4e194bc127dc13dca1f8067c19
+DIST xwallpaper-0.7.4.tar.xz 86432 BLAKE2B c10a69ab5734e43e99a746872bff427797e1d8f9de06d241fa81435036527b029031bb49733cf2119e8725883f20b9253b779ef9113d32d1b4f77bd73511a76a SHA512 f6eaf41befe724ad55d14f607bdfe9d05c79139054deb6590198ce767cf42173f068459dd894b284f3e8dbc95fc482d8ed7ed1c615f7b72b249897a6a01d51ba
diff --git a/x11-misc/xwallpaper/xwallpaper-0.7.4.ebuild b/x11-misc/xwallpaper/xwallpaper-0.7.4.ebuild
new file mode 100644
index 000000000000..70132cc575a5
--- /dev/null
+++ b/x11-misc/xwallpaper/xwallpaper-0.7.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Wallpaper setting utility for X"
+HOMEPAGE="https://github.com/stoeckmann/xwallpaper"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/stoeckmann/${PN}.git"
+else
+ SRC_URI="https://github.com/stoeckmann/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="+jpeg +png seccomp xpm"
+
+RDEPEND="
+ x11-libs/pixman
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ png? ( media-libs/libpng:0= )
+ seccomp? ( >=sys-libs/libseccomp-2.3.1:0= )
+ xpm? ( x11-libs/libXpm )
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_with jpeg)
+ $(use_with png)
+ $(use_with seccomp)
+ $(use_with xpm)
+ --with-randr
+ )
+ econf "${myconf[@]}"
+}