summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9-r1.ebuild (renamed from x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9.ebuild)12
1 files changed, 7 insertions, 5 deletions
diff --git a/x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9.ebuild b/x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9-r1.ebuild
index bcab32de50ca..b4f28a884834 100644
--- a/x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9.ebuild
+++ b/x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=6
MY_PN=${PN/oroborus-//}
@@ -20,13 +20,15 @@ RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_PN}-${PV}
+DOCS=( README docs/example_rc debian/changelog )
+
src_prepare() {
+ default
sed -e "s: -g -O2 -Wall::" \
-e "/^install:/s/install-docs//" \
-i Makefile.in || die
}
-src_install() {
- emake DESTDIR="${D}" install
- dodoc README docs/example_rc debian/changelog
+src_compile() {
+ emake VERBOSE=1
}