summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/safeeyes/Manifest1
-rw-r--r--x11-misc/safeeyes/safeeyes-2.0.9-r2.ebuild (renamed from x11-misc/safeeyes/safeeyes-2.0.9-r1.ebuild)4
-rw-r--r--x11-misc/safeeyes/safeeyes-2.1.1.ebuild51
3 files changed, 55 insertions, 1 deletions
diff --git a/x11-misc/safeeyes/Manifest b/x11-misc/safeeyes/Manifest
index 5ad0f9486da4..21a2a15d608c 100644
--- a/x11-misc/safeeyes/Manifest
+++ b/x11-misc/safeeyes/Manifest
@@ -1 +1,2 @@
DIST safeeyes-2.0.9.tar.gz 291147 BLAKE2B 61f56b7c73964f1663eff4da7965c54ff413535d55fcb3c4dbe2b5caef6f1d8e7330d5191711b87f274cbbf4458d0dff2c0dd6f5531755c556d81455438b46cc SHA512 6a168686faa716bc1da9966250bb55654ccab926775207ff1c2104b2da802ccbd50f916ed9f7cec55ffe2b5b12ea63b5bdefcfbf35f044a7fb9ba9cb4918b2b2
+DIST safeeyes-2.1.1.tar.gz 342791 BLAKE2B 0051267daacb1a8f5dcd6c88c0132d09483cc5181c59a19f34b956ea97672a44fbefc78b8b1ec2223428df159dab3074280afd3069618dc3b3257f3703e9078e SHA512 ad1f7810646010902b30effc899743c986a5bc56734f6ded0f22f0e428ec772b419aa11348d75c406f931b126737a809fabf9e029a4936976f889714629ac0b1
diff --git a/x11-misc/safeeyes/safeeyes-2.0.9-r1.ebuild b/x11-misc/safeeyes/safeeyes-2.0.9-r2.ebuild
index fe34e0ec4707..645b84ffc08d 100644
--- a/x11-misc/safeeyes/safeeyes-2.0.9-r1.ebuild
+++ b/x11-misc/safeeyes/safeeyes-2.0.9-r2.ebuild
@@ -22,7 +22,7 @@ DEPEND="${CDEPEND}
>=dev-python/setuptools-38.6.0[${PYTHON_USEDEP}]
"
RDEPEND="${CDEPEND}
- dev-libs/libappindicator:3
+ dev-libs/libappindicator:3[introspection]
dev-python/Babel[${PYTHON_USEDEP}]
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
@@ -30,6 +30,8 @@ RDEPEND="${CDEPEND}
dev-python/python-xlib[${PYTHON_USEDEP}]
media-sound/alsa-utils
x11-apps/xprop
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
x11-misc/xprintidle
"
diff --git a/x11-misc/safeeyes/safeeyes-2.1.1.ebuild b/x11-misc/safeeyes/safeeyes-2.1.1.ebuild
new file mode 100644
index 000000000000..99a979b206a0
--- /dev/null
+++ b/x11-misc/safeeyes/safeeyes-2.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit xdg distutils-r1
+
+DESCRIPTION="Linux alternative to EyeLeo"
+HOMEPAGE="https://github.com/slgobinath/SafeEyes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="${PYTHON_DEPS}"
+DEPEND="${CDEPEND}
+ >=dev-python/setuptools-38.6.0[${PYTHON_USEDEP}]
+ "
+RDEPEND="${CDEPEND}
+ dev-libs/libappindicator:3[introspection]
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/croniter[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ media-sound/alsa-utils
+ x11-apps/xprop
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-misc/xprintidle
+ "
+
+DOCS=(
+ README.md
+)
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}