summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/gmrun/Manifest1
-rw-r--r--x11-misc/gmrun/gmrun-1.4w.ebuild36
-rw-r--r--x11-misc/gmrun/metadata.xml5
3 files changed, 41 insertions, 1 deletions
diff --git a/x11-misc/gmrun/Manifest b/x11-misc/gmrun/Manifest
index 0c1fd75d5ce5..8087db6e09bf 100644
--- a/x11-misc/gmrun/Manifest
+++ b/x11-misc/gmrun/Manifest
@@ -1 +1,2 @@
DIST gmrun-0.9.2.tar.gz 66097 BLAKE2B 3b8f253e8d683d02c8b6cc8da3d54103b53c6b9ebd4d90b4675325809f592f407a32532e6f0d3d3a112f5c7b9304eaae75bc3ba7f1e1b372614d95206edf0da3 SHA512 3ce881463c23b6c2c39b4d41ff98f3d4a2b77f45a46d4ac43d8bbf726fcb3769b643436932714f9f5c22b855188928453810468d165af2c2433059a0149d6422
+DIST gmrun-1.4w.tar.xz 43304 BLAKE2B 14c4ffc0770b37d851ad101c7967f691801bf2e95abb8c7fc06abc7c39f94ffac289253febb51bdba6e5237abdea38981e8072ceb997fb410620f691b8fc7ae7 SHA512 3e36304782d4d288abf2e81b4dee60230d262fa9e3ca8ab236d52619f0a226cfa95c8cc830e6506308ed65191ff7295501a9dfe162b54d67ce1f9154d33d9473
diff --git a/x11-misc/gmrun/gmrun-1.4w.ebuild b/x11-misc/gmrun/gmrun-1.4w.ebuild
new file mode 100644
index 000000000000..0d37c5769256
--- /dev/null
+++ b/x11-misc/gmrun/gmrun-1.4w.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WdesktopX/${PN}.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://github.com/WdesktopX/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~mips ~ppc x86"
+fi
+
+DESCRIPTION="A GTK-2 based launcher box with bash style auto completion!"
+HOMEPAGE="https://github.com/WdesktopX/gmrun/"
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="elibc_glibc nls xdg"
+
+RDEPEND="
+ x11-libs/gtk+:3
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ elibc_glibc? ( >=sys-libs/glibc-2.10 )"
+
+src_configure() {
+ econf --disable-gtk2 $(use_enable nls) $(use_enable xdg)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README.md
+}
diff --git a/x11-misc/gmrun/metadata.xml b/x11-misc/gmrun/metadata.xml
index 55a75350739c..c6596064216b 100644
--- a/x11-misc/gmrun/metadata.xml
+++ b/x11-misc/gmrun/metadata.xml
@@ -18,6 +18,9 @@
features include slim design and bash style auto-completion.
</longdescription>
<upstream>
- <remote-id type="sourceforge">gmrun</remote-id>
+ <remote-id type="github">WdesktopX/gmrun</remote-id>
</upstream>
+ <use>
+ <flag name="xdg">Enable xdf spec for configuration and history file location</flag>
+ </use>
</pkgmetadata>