summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/rofi/rofi-1.7.5.ebuild10
-rw-r--r--x11-misc/rofi/rofi-9999.ebuild (renamed from x11-misc/rofi/rofi-99999.ebuild)35
2 files changed, 32 insertions, 13 deletions
diff --git a/x11-misc/rofi/rofi-1.7.5.ebuild b/x11-misc/rofi/rofi-1.7.5.ebuild
index 7f25753ea807..8e9a841cca71 100644
--- a/x11-misc/rofi/rofi-1.7.5.ebuild
+++ b/x11-misc/rofi/rofi-1.7.5.ebuild
@@ -7,11 +7,17 @@ inherit autotools toolchain-funcs xdg-utils
DESCRIPTION="A window switcher, run dialog and dmenu replacement"
HOMEPAGE="https://github.com/davatorium/rofi"
-SRC_URI="https://github.com/davatorium/rofi/releases/download/${PV}/${P}.tar.xz"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/davatorium/rofi"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/davatorium/rofi/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="amd64 arm64 x86"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 arm64 x86"
IUSE="+drun test +windowmode"
RESTRICT="!test? ( test )"
diff --git a/x11-misc/rofi/rofi-99999.ebuild b/x11-misc/rofi/rofi-9999.ebuild
index 88dba687d9d8..8e9a841cca71 100644
--- a/x11-misc/rofi/rofi-99999.ebuild
+++ b/x11-misc/rofi/rofi-9999.ebuild
@@ -1,17 +1,23 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools git-r3 toolchain-funcs
+inherit autotools toolchain-funcs xdg-utils
DESCRIPTION="A window switcher, run dialog and dmenu replacement"
HOMEPAGE="https://github.com/davatorium/rofi"
-EGIT_REPO_URI="https://github.com/davatorium/rofi"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/davatorium/rofi"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/davatorium/rofi/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="amd64 arm64 x86"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS=""
IUSE="+drun test +windowmode"
RESTRICT="!test? ( test )"
@@ -22,19 +28,15 @@ BDEPEND="
"
RDEPEND="
dev-libs/glib:2
- gnome-base/librsvg:2
- media-libs/freetype
- virtual/jpeg
x11-libs/cairo[X,xcb(+)]
- x11-libs/libXft
- x11-libs/libXinerama
- x11-libs/libxcb
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libxcb:=
x11-libs/libxkbcommon[X]
x11-libs/pango[X]
x11-libs/startup-notification
x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
x11-libs/xcb-util-wm
- x11-libs/xcb-util-xrm
x11-misc/xkeyboard-config
"
DEPEND="
@@ -52,6 +54,9 @@ src_configure() {
# Doesn't work with reflex, bug #887049
export LEX=flex
+ # Requires bison, see https://bugs.gentoo.org/894634.
+ unset YACC
+
tc-export CC
local myeconfargs=(
@@ -61,3 +66,11 @@ src_configure() {
)
econf "${myeconfargs[@]}"
}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}