summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/gkrellfire/gkrellfire-0.4.2-r2.ebuild')
-rw-r--r--x11-plugins/gkrellfire/gkrellfire-0.4.2-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11-plugins/gkrellfire/gkrellfire-0.4.2-r2.ebuild b/x11-plugins/gkrellfire/gkrellfire-0.4.2-r2.ebuild
new file mode 100644
index 000000000000..bfb9e04f0dad
--- /dev/null
+++ b/x11-plugins/gkrellfire/gkrellfire-0.4.2-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="CPU load flames for GKrellM 2"
+HOMEPAGE="http://people.freenet.de/thomas-steinke"
+SRC_URI="ftp://ftp.freebsd.org/pub/FreeBSD/ports/distfiles/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="app-admin/gkrellm:2[X]"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/fix-CC-CFLAGS-LDFLAGS-handling.patch
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}