summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/gkwebmon')
-rw-r--r--x11-plugins/gkwebmon/Manifest2
-rw-r--r--x11-plugins/gkwebmon/files/gkwebmon-0.2-cc-cflags-ldflags.patch6
-rw-r--r--x11-plugins/gkwebmon/gkwebmon-0.2-r3.ebuild33
-rw-r--r--x11-plugins/gkwebmon/gkwebmon-0.2.1.ebuild (renamed from x11-plugins/gkwebmon/gkwebmon-0.2-r2.ebuild)19
-rw-r--r--x11-plugins/gkwebmon/metadata.xml5
5 files changed, 15 insertions, 50 deletions
diff --git a/x11-plugins/gkwebmon/Manifest b/x11-plugins/gkwebmon/Manifest
index d8d8da7ff8de..5e9a20f7cd6e 100644
--- a/x11-plugins/gkwebmon/Manifest
+++ b/x11-plugins/gkwebmon/Manifest
@@ -1 +1 @@
-DIST gkwebmon-0.2.tgz 14163 BLAKE2B c6c0c9352e2f68eca56f981abb8188a7a300604c8c0fc05c1b0b95f0cdc117c12e55aeace66f9c3dcc16a13acb2b44683a77de36a83d9e9b7c273ec619173235 SHA512 0af4eaa8636b43232e209e6381a3852eb92b9505da4b19e31137766f4bee7977bf4e4bed40518df0fcc3aef2dc62767c85169e70f1fbfc738bb428ae8affac63
+DIST gkwebmon-0.2.1.tgz 14576 BLAKE2B 12014eef1f73c4b398aeb7e5f5e7821561dd01c2de7d1705f567d60252ce7ce376266612602b58f90bc16dc587d8c5449d791dfd01a9c810fe9c6fb6d05970ce SHA512 f71a106372018c55ca1e31140aedd669df66cb6c3e9613fe5341831fad55e8bdd23c46281c38c553c09d350436bc1e44cee07602a24fc637c7f21f4e0d50cc39
diff --git a/x11-plugins/gkwebmon/files/gkwebmon-0.2-cc-cflags-ldflags.patch b/x11-plugins/gkwebmon/files/gkwebmon-0.2-cc-cflags-ldflags.patch
index 5ffe8f12ed42..4c5c786cfed6 100644
--- a/x11-plugins/gkwebmon/files/gkwebmon-0.2-cc-cflags-ldflags.patch
+++ b/x11-plugins/gkwebmon/files/gkwebmon-0.2-cc-cflags-ldflags.patch
@@ -4,12 +4,6 @@ Date: Mon, 29 Aug 2016 20:44:45 -0400
Subject: [PATCH 1/1] Clean up variable usage in Makefile to support LDFLAGS
and friends.
----
- Makefile | 18 +++++++-----------
- 1 file changed, 7 insertions(+), 11 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index b422e79..d89977f 100644
--- a/Makefile
+++ b/Makefile
@@ -3,23 +3,19 @@
diff --git a/x11-plugins/gkwebmon/gkwebmon-0.2-r3.ebuild b/x11-plugins/gkwebmon/gkwebmon-0.2-r3.ebuild
deleted file mode 100644
index ed50957c7417..000000000000
--- a/x11-plugins/gkwebmon/gkwebmon-0.2-r3.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit gkrellm-plugin toolchain-funcs
-
-DESCRIPTION="A web monitor plugin for GKrellM2"
-HOMEPAGE="http://gkwebmon.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-
-# The Makefile links with -lssl.
-RDEPEND="app-admin/gkrellm:2[X]
- dev-libs/glib:2
- dev-libs/openssl
- x11-libs/gtk+:2"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${P}-cc-cflags-ldflags.patch
- "${FILESDIR}"/${P}-fno-common.patch
-)
-
-src_compile() {
- tc-export PKG_CONFIG
-
- emake CC="$(tc-getCC)"
-}
diff --git a/x11-plugins/gkwebmon/gkwebmon-0.2-r2.ebuild b/x11-plugins/gkwebmon/gkwebmon-0.2.1.ebuild
index b915fe941137..49e90ed9d3a0 100644
--- a/x11-plugins/gkwebmon/gkwebmon-0.2-r2.ebuild
+++ b/x11-plugins/gkwebmon/gkwebmon-0.2.1.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit gkrellm-plugin toolchain-funcs
DESCRIPTION="A web monitor plugin for GKrellM2"
HOMEPAGE="http://gkwebmon.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
@@ -16,15 +16,16 @@ KEYWORDS="~alpha ~amd64 ~ppc ~sparc x86"
# The Makefile links with -lssl.
RDEPEND="
app-admin/gkrellm:2[X]
- dev-libs/openssl:0="
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
+ dev-libs/glib:2
+ dev-libs/openssl:=
+ x11-libs/gtk+:2
"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}"/${P}-cc-cflags-ldflags.patch
- "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${PN}-0.2-cc-cflags-ldflags.patch
+ "${FILESDIR}"/${PN}-0.2-fno-common.patch
)
src_compile() {
diff --git a/x11-plugins/gkwebmon/metadata.xml b/x11-plugins/gkwebmon/metadata.xml
index 4c545e85f783..87b87bf394bb 100644
--- a/x11-plugins/gkwebmon/metadata.xml
+++ b/x11-plugins/gkwebmon/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
<upstream>
<remote-id type="sourceforge">gkwebmon</remote-id>
</upstream>